[2019.33840 macOS 10.14.3] webcams are recognized but no video stream

Hello,

Since the last build (33840), the Facetime webcam, the logitech c930, and also logitech c925 does not provide video stream but are visible in the Cameras parameter menu.
No other application running.
“Library” parameter is set to “AVFoundation (macOS)".
TD is granted access to camera in privacy settings.

All these webcams worked perfectly in build 33020.
.
Thank you for your help!

Could you screen grab the “About this Mac” dialog so we can see your system specs. This has been reported by a few others but we can’t reproduce it yet.

Hi @ben, reporting the same problem here.
Bought a brand new Mac mini for a client, one of the last Intel Macs, and getting black from all video in device sources I try. This is a brand new machine with no other software installed. A Video Device In TOP recognizes the devices, just shows black.

I’m using a Magewell USB Capture HDMI 4k+, but have also tried two random webcams.
I’ve tried both TD 2019.20700, which I have licensed, and 2020.28110 in non-commercial mode, both with the same results. The Security and Privacy control panel has allowed Touch access to the camera, and I’ve given it Full Disk Access as well, just to be safe. No dice.

If I launch Photo Booth or FaceTime, they see the capture stream just fine. I’ve also tried all three devices in Touch on other computers (a windows 10 pc and a 2013 MacBook Pro running Mojave) and they see the capture streams as well.

I have not tried upgrading the old laptop or downgrading the new Mac mini, so I’ll report back if it looks like a Big Sur issue. Just realized this thread is a year old, so fingers crossed you have a known workaround by now.

Thanks!
–dbg

It could be Big Sur as we only have a couple of machines tested on that so far. I would be interested if you downgrade and it works. I’d recommend testing with 2020.28110 as the other build you mention is over a year old (tho I expect they should behave the same).

Sad news, @ben. I’ve downgraded to Mojave on that machine and I’m still seeing black. I’ve tried both the current release (2020.28110) and the release that @bunqbox mentioned was working, 2019.33020, neither one with success. Again, I see a signal when viewing in FaceTime or Photobooth, and the hardware works in Touch on both a windows 10 box and an older mac - so I’m really stumped.
Maybe it’s some nuttiness with the new T2 security chip?

Since this is a client-purchased mac and we’re installing in a couple of weeks, I may just need to try a different capture device. Do you have a recommended product that can accept a 4k HDMI signal and is tested on recent mac hardware?

Thanks for all your help so far,
–dbg

If it helps, the new mac mini that’s not working has an Intel UHD Graphics 630 chipset,
the old Macbook Pro that’s working has two GPUs, an Intel Iris Pro and a GeForce GT 750M

Just wondering if you tried installing the Magewell SDK? http://www.magewell.com/downloads

Since macOS uses standardized drivers it could just be GPU incompatibility. We do not have the 4K magewell around for testing unfortunately. Another tip for Mojave, make sure you apply patches up to 10.14.2+ as the first two releases 10.14.0 and 10.14.1 had some bad driver bugs.

@ben Yeah, I’m running 10.14.6, but good lookin out. There’s no SDK to install for mac, just some C libraries and a testing utility (which does see the input stream, but still doesn’t help Touch).

I did try running their USBCaptureUtility, but that’s mainly for setting EDIDs and such. And it didn’t help anyway. Again, this problem isn’t unique to the Magewell product, it seems to be all webcam signals. GPU incompatibility sounds like the best bet here, which is unfortunate.

I did have one brief glimmer of hope. I accidentally got it to work in Touch, then was able to repeat it, but under weird enough circumstances that I can’t use them in production. Maybe this will help sleuth out what’s going on?

I had the Magewell device plugged in then additionally plugged in a webcam. I checked in Touch and it was seeing black for both. Then I opened up the mac’s built-in PhotoBooth app, and as expected, could see the webcam signal. I switched back to Touch and toggled the Video Device In TOP off and back on and Lo and Behold! There was the webcam feed in Touch. Then I switched to the Magewell input and Touch could see that as well.

I rebooted and was able to repeat those steps to see the Magewell in Touch - but I can’t get it to work without having the webcam also attached, or without running PhotoBooth or FaceTime (or anything else that can see the cam feed), OR without toggling the TOP off and on.

It’s super bizarre, but it proves that the webcam signal CAN get into touch on this graphics card. I just have no idea what obscure library in what stack has to get invoked to make it happen.

Hope any of that helps. Otherwise looks like I’ll be buying a BlackMagic card or something.
Thanks for all your help so far.

One last question, are you going directly into one of the Mac Mini’s USB3.0 type-A ports or are you running through an adaptor and one of the USB-C ports by chance. I would make sure no adaptors are in the USB signal path.

Just to confirm, we are talking about this exact model? https://www.magewell.com/products/usb-capture-hdmi-4k-plus

Confirmed, that exact model, as well as a couple different random webcams I had lying around. And yeah, straight into the rear USB3 port.

With an AJA box or the like I’m sure we’ll be fine. At this point I’m more curious about the mystery of it all. Never seen anything quite like it.

I’m exploring one last possibility. I thought I’d try to rig up a Processing -> Syphon -> Touch workaround, but privacy permissions got in the way. Touch is smart enough to trigger the MacOS dialogue asking for access to the camera, but my processing sketch just crashed with the following error:
BaseSrc: [avfvideosrc0] : Device video access permission has just been denied. Target VM failed to initialize.

I wonder if, even though the Touch app itself has OS level permission to access the camera, there’s some AV Foundation layer that isn’t getting permission, and isn’t smart enough to trigger a system dialogue asking for it. I’m going to keep poking around, and I’ll report back if I find anything.