[2020.455XXX] Bug: tag names of installed builds disappear after new install

I’m superhappy with the custom tag names I can give to every TouchDesigner install, as on every given moment I have multiple build installed for different projects.

The issue is the install tag names ‘disappear’ from windows after a while on my machines.
This issue is for me hard to trace down or to reproduce. But today I saw clearly a tag name was removed directly after I installed a new TD build.

2020.28110 (no tag)
2020.45520 (had a tag)

now I installed an extra parallel build and gave it a tag, result:
2020.28110 (no tag)
2020.45520 (no tag)
2020.45930 (has a tag)

so my tag for 45520 had disappeared from Windows.


tagging @snaut as installer guru :wink:

Hey @nettoyeur,

yikes - I have seen this usually after a windows update.
For this feature, I’m writing into a registry key that sometimes seems to get reset.
On the lookout for a better solution.


1 Like

Would it be possible to edit that post-installation wise ?

For example I found this entry in regedit:

If I modify the data for this entry - would it then show up in my open with menu ?

I am asking because I am a bit of a chicken when it comes to modify my registry - so I don’t just try it out …:slight_smile:

Yeah, known issue for Windows Updates Windows update shenanigans

Just discovered that it’s trivial to restore/write any program “tag name” instantly, by a quick manual edit using the windows Registry Editor. This will only adjust the program name in the Windows Explorer RMB “Open With” menu, which is good enough for my case.

  1. Open Registry Editor, and navigate to:
    Computer\HKEY_CURRENT_USER\Software\Classes\Local Settings\Software\Microsoft\Windows\Shell\MuiCache

  2. Locate the FriendlyAppName key for your TouchDesigner build,and adjust its value.

  3. Done


1 Like

Thanks for the tips @nettoyeur

yup - and when building the installer to write into that key the term “Cache” made me hesitate a bit but went ahead anyways … meh - from what I have read this is the only place I can control this.

1 Like

Also if it’s of any help (and maybe a checkbox to add to the installer?) I don’t even bother with the “Open With” shenanigans and just manually put my own shortcuts in the “Send to” menu.

The quick way to get there is to type shell:sendto into a Run dialog and then just put your own shortcuts with their own names in there and it will show up in the “Send to” menu when you right click on any file - and I mean ANY file, which is actually handy for opening things in TD that may not be associated with TD by default. And the names of those shortcuts have never changed for me since I’ve been doing that, while the “Open with” menu seems to regularly reset itself.

The only downside is that you also have to delete those shortcuts when you uninstall or replace an older version of TD, but it’s become muscle memory for me to hit Win-R shell:sendto after any install of anything really that it’s not a big deal to do some pruning from time to time.

I don’t know if that menu is something that Windows Installers have access to, but it might be worth putting a checkbox in the installer for “Add this build to the Send to Menu” or something. Come to think of it I feel like I remember similar options being in other softwares’ installers so maybe it is doable.

I used to do this with extract option before the new installer, but I really hated how Windows keep repopulating that sendto folder with deleted system items after some Windows Updates (and thus breaking my OCD order of menu entries). I do find the new Open With… better than the old ‘extract’ and send to option (until the day of those dreaded updates) mostly because the installer nicely handles my multiple parallel builds now and I don’t need to shuffle new shortcuts around. However, I’m a special case installing anywhere from 2-10 new versions a day lol. :grimacing:

Thank you nettoyeur for the confirmation and the hint that I have to go to HKEY_CURRENT_USER and not HKEY_CLASSES_ROOT (the former overwrites to later)

I am still onWin7 and the

didn’t do it for me, but modifying the normal TouchDesigner.exe value does it. :slight_smile: -
might be a Win10 / 7 change…