2021.12380: PBR Environment light needs regular light

Hi there,

I noticed an issue concerning the pbr materials. The environment lights don’t seem to work without including a regular lightCOMP. It also seems to work if the dimmer of regular light is set to 0.
See attached tox.

Cheers,
tim

EnvironmentLightBug.tox (2.2 KB)

Sorry about that, bug was introduced trying to fix those mac M1 shading issues. Will be fixed in builds 2021.12490 and later.

1 Like

Built 2021.12380 fixed the M1 shading issue. Thanks.

But like @timgerritsen I have the same problem when using environment light. When will the new built to fix this be released? Thank you.

Hi @SPitt there is a new build 2021.13610 that fixes the Environment light issue.

Hi @ben, Sorry to have to report that it’s still not working. It’s working in the last 2020 built. But Still not for with the 2021.13610 on Apple M1

@timgerritsen can you concur that’s it’s the case also on your M1?

I think the fix for the M1 shading didn’t catch all cases, still running into bugs with the OpenGL driver there. I’m going to try another fix for the next build we post.

1 Like

Hey, I met the same problem when I used PBR as the material. I am a new user of M1 and TouchDesigner, and I found that many of the problems I reported were related to this system. The capability of TD is powerful, but the user experience is not exciting. I hope there will be a version fit for the M1 :slight_smile:

Hey, can you try this build and see if it fixes the issues for you?

1 Like

Hi @malcolm
Seems like the environment light is working, but I am experiencing a considerable drop in the FPS from 60fps to 11fps even 9 fps for the same network that I am currently working on with the last 2020 built.

The same goes for the network @timgerritsen uploaded and it takes forever to enter in a container

Its working fine for me, Thanks!

Hi! I´m having the same problem, but I am working on Windows 10, using Nvidia 2060rtx.
With regular light COMP, or even ambient light everyhing works fine, but I have been trying with environment light and different hdri maps and nothing seems to work

Hi! Just to comment that I´ve already made environment light works. It was an issue about uploading my graphic card drivers, but also a mistake inside geo COMP, sorry! Everything is working fine :slight_smile:

1 Like

Hi Friends, I am having the same problem with the environment light. It is not even working with a regular light as some people mentioned before.

I am on build 099 2021.13610 using a mac mini M1 16gb memory 1tb SSD.

@alephoy Can you try the hotfix build that Malcolm shared in this thread a few posts ago, the version is 2021.13830 and it should have it fixed finally.

@ben and @Malcolm as submitted earlier the Environment light works but having considerable drop of FPS and freeze when entering nested containers. Do you have any leads on why? Thx

Still on my list to look at. So far I havn’t been able to reproduce the issue. Trying different macs

Any change you are using an animated texture on the Environment Map? This will kill frame rate, environment maps are typically static.
I ran this file on my 9 year old mac and it runs normally, so wondering if you have any customization to your file different from Tim’s original example.

For test on the latest 2021 built I am using, the network provided by @timgerritsen. So no animated map.

But in another network I am using a animated Ramp as an environment map with the 2020 latest built and it works fine.

Well using an animated environment map will be super heavy, its typically avoided unless you dial down the Env Map Quality a bunch.