Annoying behavior with datexec

its easy to connect the output of a chop to a chopexecDAT with the output r.click op create dialog, but doing so with a tableDAT clears the contents of the datexec and flags a warning that datexec1 needs to be text. I wish the default behavior was that the datexec was smart enough to detect a table, and either treated that input as if it were in the ‘dat’ parameter, or added itself to the ‘dat’ parameter instead of plugging itself in, since the datexec for working with tables by design, and its the natural flow to want to connect a table to it.

This would save the regular mistake of remembering that the datexec input doesn’t actually want the dat, just a script (rarely the behavior one would use), then having to delete and recreate it separately, which i feel like i forget about regularly and i’ll bet I’m not the only one

can we make the common use case the default behavior?

I understand the inconvenience, but we’re trying to avoid odd exceptions like this.