ASIO Steinberg USB Audio Interface

Dear Derivative Team,

I have seen that the ASIO Devices are now supported on the New 088 and
I bought an External Audio Card ( steinberg.net/en/products/au … eries.html )
Using a Audio Device IN chop i am not getting any Audio In. I am using latest 088 release and tried on 2 different computers. Input1 and Input2 on the CHOP are both greyed up aswell.
The Drivers are installed correctly and even Touch “see” the device as shown here i.imgur.com/Nz0ti2t.png
Is there any way to work around this? I spent quiet few monew on this hardware thinking it was going to work.
Thanks in advance

Mattia

Hi Mattia.

Input1 and Input2 parameters only apply to DirectSound option.

Are you getting any warning on the CHOP?
Or maybe in the console (Alt+C, then clear it, then put down the Audio Device In, and set it to ASIO)

Are you running other applications using that ASIO?
From my understanding, only one application can output to the ASIO device at a time.

Are you able to use the native audio control panel to verify audio is in fact reaching the device?

-Rob.

Hello Rob,

i am willing to use this Audio Device mainly to get Audio IN not to output it,
I am not using other softwares while i try to use with TouchDesigner,
here is a screenshot of control panel logs and Windows sounds manager, Record device,
Audio reaches the computer but not the program.

Am i doing something wrong?

Thanks again

puu.sh/4yype.png

It seems your setup is correct. The audio is being fed directly to the hardware, and not piped in through another program that may be accessing the asio device drivers?
You’re just getting two flat lines? Is that number of channels correct at least?
Are you muting the sound at any point, or setting volume to zero?
Is this in a new TouchDesigner session?

Another good test just to confirm your device and Windows settings are configured correctly is can you use this input device with other software and it works? Skype is an easy one to try with.

Yes, the audio is being fed directly to the hardware, I am just getting two flat lines and the number of channels cannot be set.
I am not muting the sound at any point unfortunately and neither set the volume to zero.
This is a new ToucDesigner session.

I ve tried with skype just now and under configuration settings the microphone “line in” works.

I am not sure if this helps but even if the device is not plugged in, on new TouchDesigner sessions i can select it as a interface anyways.

Hmm.
A bit stumped.
I’ll see if we can think of anything else here at the office.

Which Steinburg device are you using exactly? Is it the CL1 or the CL2 (or CL2+)? We might try to get one for testing, though this will take some time for a possbile fix.

Out of curiousity, does it work in DirectSound mode? I know that isn’t likely acceptable with the increased latency and such, but just curious.

I am using CL1, I was out of town and left the device at home i will try see if it works using the DirectSound mode in about 8 hours and update the thread. Thanks again

Looks like its not working either ways :confused:

Hi Sorry for the long follow up.
We’ve since acquired a Steinberg CL1 and confirmed that it does seem to work properly.
Do you still have access to the device?
Could you try with the latest build?

Hello,

I am using a Steinberg UR22mkII 24 bit and I have no luck getting audio in Touch from the usb audio interface. Is that possible? Asio 4all not helping also…Audio Device in recognisez ASIO and then Device > Yamaha Steinberg asio but they work only with line input mic/instrument. (this is something that I tested) but no luck from playing sound from YT or Soundcloud. Do anyone have any idea how to get audio in touch? Ver Touch (latest)
Thanks