audioAnalysis Neutone issue and fix

Win11 TD2023.11600 not sure if this is the right forum section for this, feel free to move it

So I noticed the neu addition Neutone to audioAnalysis in the palette recently and wanted to test it. Went through the instructions found in the comment box inside, and was met with an empty white Window for the VST. Same deal in Ableton. Also, this issue doesn’t come up for everyone, it’s machine specific.

So I wrote in Neutone’s discord, and they were kind enough to reach out and have a call to try and fix it temporarily, as they are working on a general update to solve this issue.

The fix for now that worked in TD (and honestly not sure which one was the final solve, best do all of them):

  • Update Microsoft Edge WebView2 Runtime
  • Look for WebView2Loader.dll in C:\Program Files\Common Files\VST3\neutone.vst3\Contents\Resources\webview — or other places (Use Everything)
  • Paste it next to C:\Program Files\Common Files\VST3\neutone.vst3\Contents\x86_64-win
  • You can also try pasting it in TD’s bin folder if all else fails
  • But probably the thing that fixed it after all, was deleting the audiovst1 CHOP and popping down a new one and looking for the same neutone.vst3this might indicate that the VST CHOP shipped in aduioAnalysis loads a wrong/cached state of the plugin.
  • Now the plugin works in TD (and Bitwig, still not in Ableton)

Thanks again to Andrew from Neutone for the help!