Blending FBX Character Animation Takes

Hi,

I import an animated FBX Character, take001 gets generated as a CHOP. Than I import the same Character, but with a different animation.
Now I copy take001 from the second Character into the animation COMP of the first character ( it gets renamed to take002 ). I wire these two takes into a switch CHOP, which I connect to the out chop. Switching works fine, but when I wire the takes into a cross CHOP only take001 works fine, but fading to take002 explodes the character in a really wired way.

Is there another ( the right ) way to import FBX takes and get them cross faded ?

How is rotation handled ? Is touch aware of rotation channels and blends them in Quaternion Space ?

Cheers, searching for the Pivot of my Soul, PP !!!

Just to double check a few basics . . . make sure you have the same # of channels all named the same and in the same order. Also, make sure the blending works in your source animation package, I’ve seen cases where mapping or based poses are different between takes.

If you can post an example I’ll take a look, this should work.

So you think my approach was the right one ?
But if the chhnnel naming and numbering would be different, shouldn’t the switch CHOP screw it up as well ?

Any ideas about the quaternions ? Euler rotations blendet on per channel basis do look wired, but at 100 % blend weight the result should be right, at least, but it isn’t.

My setup is kind of complicated, will prepare a simpler one.

Cheers, searching for the Pivot of my Soul, PP !!!

Hey, we just added Quaternion blending as a feature to the Blend CHOP today. It requires a FTE-commercial or Pro license though.
You can tag your channels as quaternion rotations using the Attribute CHOP, then feed it into the Blend CHOP (in builds 5304 or later), turn on the feature, and it’ll use quaternions.

You’re right that it should look correct with 100% blend on a specific input though…

Sounds great, unfortunatelly I started with touch 077 today, and of course only FTE. Any chance that this feature gets into FTE ? Would like to see how far I can get with Characters.

Btw, I tested the blend CHOP as well, the first channel I connected to a constant CHOP to edit the weights, but nothing happened at all, even the original animation didn’t get through. The cross CHOP worked, but screwed up as mentioned. Anyway, will try to import an FBX with multiple takes, maybe teflonjf is right and I screwed up somewhere.

Cheers, searching for the Pivot of my Soul, PP !!!

Yeah, in theory the switch and cross should function about the same, though I’ve seen ordering of channels cause problems when I didn’t expect. You can sort the all the takes using one of them as reference, maybe that will help. Of course how different the moves are is very important in blending mocap and ultimately quaternions will be your best bet for quality. But even without your character shouldn’t explode, though it may have a few issues, depending on the moves you are blending.

Anyway, send a file if you can and I’ll see if I can provide anything more useful.

Jeff

I created the example FBX file, but with this file Touch was crashing very often and I cannot save as .toe ( details at the given link ) so posted a bug report:

Lots of crashes while blending FBX Takes
http://www.derivative.ca/Forum/viewtopic.php?f=12&t=2107

You’ll find the FBX file attached. This time even the switch node is not working as expected, but the takes work proper in Motionbuilder. Do you think I miss some settings ?

Also on my machine ( GFX 280 ) I see rendering issues around wings and feet. If you see them as well, is this Z-Fighting ? If not, what could it be then ?

Cheer, searching for the Pivot of my Soul, PP !!!

Append a facet SOP to /plyDragon/mesh, turn on “Orient Polygons” and the last “Compute Normals” button. This should fix the rendering issues and the second take seems to work fine as well.

Maybe the “Orient Polygons” and “Compute Normals” combo could/should be automatically applied when loading an fbx file?

Thx, that fixed the rendering issue, but the switch and cross CHOP are still not working as expected here. I posted comparing screenshots in the bug thread.

Cheers, searching for the Pivot of my Soul, PP !!!

I can see the issue and I’ll be taking a look at it as soon as I can.

Thx. I attached one more FBX with an additional Take ( Take_Bind, and it is the first Take in the switch ) without Animation and all Joints set to their Bind Pose. Take_1 and Take_2 still screw up, but looks like they get the same amount of offset. Maybe this helps.

Cheers, searching for the Pivot of my Soul, PP !!!
Dragon_3Takes.fbx (1.37 MB)

This is an old thread but I’m running into the exact same problem, wondering if anyone has managed to figure this out? Or is Quaternion in the Blend CHOP the only solution?

No worries, found the issue. My first animation take was only taking into account Rotation X whereas my second animation take was taking into account X, Y, Z. I keyframed Y, Z for the first animation take, changing the animation very slightly to like 0.01 so TD would pick up the channels but no noticeable animation (when I tried to simply keyframe Y and Z but without changing the parameters the animation take again wouldn’t recognises Y and Z).

Basically all channels need to be accounted for in both animation takes.