Bug? AudioFileIn CHOP plays last frame first

First frame of playback seems to play the last frame of the audio. Try attached file:

audioFileInBug.zip (1.3 MB)
(zip contains .toe and .wav, just place .wav in same location as .toe)

Let the whole timeline loop around. The Audio File In CHOP is locked to timeline, and its play parameter is set to play starting at timeline frame 1. So then why am I hearing the last frame of the .wav right at the beginning? Is this a bug?

If I change play mode to sequential and cue the file manually, it has no such issue, and the start of playback is clean. Only happens when I lock to timeline, and begin playback at frame 1.

EDIT: I know it’s not my audio out or hardware, because here’s a trail of the Audio File In CHOP by itself, and you can see the spike:

EDIT 2: It also happens when simply turning the Audio File In CHOP’s Volume par from 0 to 1 on frame 1, instead of using the Play par.

EDIT 3: Small error in documentation:

image

Play is not disabled in this mode.

Hey @matijaerceg

Apologies for the delay.

I had a look and what I did was play back the file in Audition to inspect + loop.

It could be an issue with the Play par On / Off in your sample file. You turn off the Play par at frame 960 and it will turn back on at frame 1. I think the spike might be some kind of “leftover” from when the Play par previously turned off. But that will need the input of a developer to confirm.

What I found is that using the Trim par and setting it to be 1-960 range like in your Play par expression does silence that spike on the first frame.

I’ll log this to have additional input from a developer.

Best,
Michel

1 Like