BUG: DMXin sACN Multicast IGMP not utilizing "Local Address" [Win10][TD22.26590]

I know I have another post more broadly speaking about this, but I think this might be one bug amongst a couple - though this is the only one I can reliably reproduce, so I am making a more focused specific bug report about it here.

When running on a computer with multiple Network Interfaces, the DMXin CHOP (in sACN mode) does not seem to use the “Local Address” parameter when deciding which interface to send out the IGMP group join / leave messages. Regardless of which IP address I put in there, WireShark shows the IGMP messages always go out the same network interface. I don’t know what is causing it to chose one specific interface, but if I disable that one, it picks another one and sticks with this new one regardless of the settings in the DMXin CHOP.

This is regardless of being in packet-per-sample or packet-per-channel mode. This is easily re-createable and viewable on WireShark, just type “igmp” (lower case) into the filter field to see only IGMP packets.

Here is me switching from Universe 81 to Universe 82 on what SHOULD be my Ethernet Connection, but notice that the leave / join packets only show up on the Loopback (Microsoft KM-Test) adapter.

Thanks for the report. Yeah, it is just sending it out on the default network interface, which is something determined by the OS. I’ll fix it so that it uses the local address parameter.

1 Like