BUG: speed CHOP jumping in per sample mode

This bugger.tox (798 Bytes) drove us crazy for a long time

In “speed per sample” mode the speed CHOP will jump if you do a blocking operation before actually triggering the speed CHOP

Just open the file and run “text1”. As the speed CHOP is triggered after the blocking call I would expect it to count smoothly

PS: in the production file we actually have a multi sample input

1 Like

So I think the reported bug is more of an UX issue. I guess turning “per sample on” will effectively turn off timeslice mode. But the timeslice toggle is still on. Would be nice if those would synchronize !

But that still leaves me with the actual problem:

how to execute a long/blocking function and after it’s finished enable a speed CHOP ?

In timeslice mode the ramp looks smooth, but if I shuffle that into a multi-sample CHOP or if I initially use “speed per sample” I will get those huge jumps (doing that in order to get samples suited for piping into a shader)

I guess the speed CHOP will start “increasing” on the frame the DAT was executed and not on the frame the blocking call in that DAT has finished (which I expected it to do).

Hope that makes sense. Any ideas ?