Buttons work in Network Editor NOT in Perform Mode

Good day all. I’m new to TouchDesigner and struggling with working buttons in a control panel.

I’m trying to build a small network to run a manual slideshow with outputs to multiple displays. The project needs manual buttons in a control panel to play the next and previous media files from a folder.
I setup the project with a Folder DAT for the slideshow source material. The Folder DAT is sorted and connected to a null.
I then built a button counter using momentary buttons with Merge, Count, Math, and Limit chops. The counter pulls the .numRows from the Folder DAT and sets the maximum limit with a loop. Finally a CHOP Exec (OffToOn) gets the counter value, finds the movie path using counter value, assigns the path to MovieIn TOP and Preloads the movie.

All above works as expected when working in the Network editor. However, when I put the project in Perform mode the buttons above are not working.

The goal is to have all the buttons on the control panel. As my buttons are all momentary I thought I could accomplish this with a .click(). In my control panel container, I made a new button connected to a Select CHOP to a CHOP Exec DAT. In perform mode this button works once, then it seems to fail to advance the counter and load the next MovieIn path.

I then recreated the entire Folder DAT and Button Counter logic in my Control Panel container. The results are the same. The counter and movie load behavior works great in the Network Editor. Yet once I put in Perform Mode the buttons work for a click or two, then stop working not advancing the counter.

Attached in a revision of the project. Any help is greatly appreciated!!!
PJHConsole0.11.5.52.toe (12.8 KB)

I’m not able to check your network but you may set your null chop at the end of your flow to « always cook « see if it fix your issue.
It is a Touch Designer feature : Only operators that contribute to the final output are cooking.
In editor mode, all operators with viewer active on screen are cooking which is not the case anymore when switching to perform mode.
You can check for cooking in the wiki.



It was the Null CHOP at the end of my button counter that was the issue. Setting the Null CHOP to ALWAYS COOK resolved the problem!

Thanks again for your help!!!