Can't configure Ouster OS0-128

Hi, I would like to see visualization from OS0-128 with OusterTOP, but I got error like the image attached and can’t configure the Lidar. I didn’t change any parameters on Ouster TOP.

Info CHOP connected to Ouster TOP shows me accel and velocity working when I grab and move the LiDAR, so I think the connection between them is established.

I can see it working on Ouster Studio on my PC, so it worked on my PC but not with TD at this moment.

Any helps welcome.
Thanks in advance!


Firmware 2.5.2
Windows 11
Build 2023.11760

Hi @chimanaco,

i see that there is no value in the Device Address parameter of the Ouster TOP - could this be the issue?

cheers
Markus

@snaut Thank you for your reply!
I got the same result even if I put the Device Address unfortunately.

Read this one. Current Ouster sensors are not really supported in TouchDesigner Official anymore.

1 Like

Yeah, unfortunately Ouster deprecated the original interface that we were using to communicate with the sensors, and unfortunately their new system has some potential conflicts with other devices that we support which has held us up getting official support in.

We do have this link for an unofficial update if you would like to try it out. It is more up to date with the 2023 releases than the link in the other post.

https://www.dropbox.com/scl/fi/3vjqilxbdf5gx1mvuexiw/TouchDesigner.2023.11624.420.exe?rlkey=budqlfwl0uh0i0yxqaenkt28d&dl=0

Thank you! Let me try this build!

HI @robmc thanks to the build you shared, I got this (point cloud view as well)!
Is this the view we expected?

I use Rev06 and Firmware 2.5.2, but can I expect Rev07 work same like this?

That all looks correct as far as I can tell.

As far as compatibility with certain revisions, we only have older hardware available here for testing, but I think it should be ok.

Ouster defines their compatibility more on the firmware version you are running. So if Rev 7 can run the same 2.5.2 firmware than it should all be the same. We’re using version 0.10.0 of the Ouster SDK so it should also work with firmware versions up to 3.1 based on this chart from their website: Ouster SDK — Ouster Sensor SDK 0.11.1 documentation

2 Likes

Thank you Rob!!!