Control a laser

I just bought a laser CS-1000-RGB at Laserworld, and a Ether dream 3 DAC to control the laser with TouchDesigner (TD).

I’ve been following the TD explanation from their website : using a Ether dream DAT chop to get the IP/Port and using a Etherdream CHOP to output the data.
In my laser chop, I also change the rate to 28000 to match the KPPS of my laser.

But nothing is happening.

Since Ether dream is definitely suppose to work with TD, I’m wondering if Etherdream works with this Laserworld laser…

Did I forgot to do something in my patch ?

Thank you for your answers!

Can we have a closer look at that Info CHOP connected to the Etherdream CHOP?
Are the values reasonable and show the device is queuing data?

Hello! Thank you for the answer. I didn’t have the laser with me so couldn’t answer but now I’m back. Here is the info CHOP…
Aussi, lorsque je débranche le ILDA le laser projète la demonstration automatique, lorsque je le rebranche tout disparait.


It looks like the Ether Dream DAT is finding the device, but for some reason the Ether Dream CHOP is not connecting to it.
Your IP and port look correct as well.

I just checked the website and it said the Ether Dream 3 is fully software compatible with earlier versions.

Have you tried the device on this software?


Yes I tried with Modulaser and the laser answers directly to what I’m doing. So connection is fine. It’s only TouchDesigner…

Do you mind making sure you have the latest firmware in case TouchDesigner is using a function that was recently updated?

Yes I downloaded the latest firmware but no changes. Also I can’t poll anymore the values to the ether dream DAT operator.
Also when I’m connected to Modulaser, the network setting appears green and connected; but when I’m connected to TouchDesigner it appears like orange and it says “AX88179A has a self-assigned IP address and will not be able to access the Internet”.

Are you running on a mac ?

Yes I’m on Mac

Hi. Could you please contact us at ?
We have some more technical suggestions we’d like to explore with you.

Thanks for your patience, and support.