crash after import the key

hello all
i’m hving TD to run in my school computer lab (2015late iMac 10.13) & my own mac notebook (2015 mbp 10.11)

they both behave in a strange way when i try to update to the latest build 2018.25000

after i type in the key in key manager
the dialog box said it is successful
but then it do not close the box but stays at the centre of the desktop

TD environment stays in grey & it seems it cannot update?

i tried re-launch TD but it then gets back to the original demo state

and by then i tried different build but all of them gets the same error

i can only using TD with the original build that i hv before so far

any idea/clue ??

Hi bjorn_ho,

If you’ve made core hardware changes (CPU/Motherboard) or operating system changes (such as reformatting or changing versions) then the previous key won’t work anymore.

Creating a new Non-Commercial key on each of those machines should fix your issue.

Here’s the link to our Key manager wiki page: docs.derivative.ca/index.php?ti … ger_Dialog

Hi there I have the same problem, has this been fixed?
Key manager just remains in the centre of the screen with everything else greyed out. Every time I try to open TD I have to create a new key as it’s not registering. Then I run out of keys!

Strangely I can select items and windows from the main screen. I also can open/ close other windows from the menu but as soon as I close the key manager window, Touch Designer closes as well.

Im admin on M1 Max loading arm version of TD
video here: