Crash when i make a reference / The Vulkan Device has returned a fatal error code

Hello, this is the first time I use the forum and I apologize if I make any mistakes.
I am working with the latest stable version of touchdesigner, version 2022.25370. When I open a new blank project and make a reference from a parameter to another object, the system crashes and throws me an error and closes. the error it gives me says vulkan device error. but i am not using anything from glsl. no matter what I do it crashes when I make a reference.
I am working on windows on a razer laptop with a nvida 2070 graphics.
the error occurs if I make the reference by dragging the value to a parameter, if I write the reference it does not give me the crash.
Does anyone feel the same? How can i fix this?

I attach an image of the error that touchdesigner throws me.
Thank you.

error touchdesigner 2022

3 Likes

Hello, I have exactly the same problem and I don’t know how to solve it.

1 Like

Same problem here, no information found online and no answers here…starting to be a real pain in the ass

1 Like

Does anyone above suffering from this bug have any dump files? They are .dmp files on Windows, and found in the Console app in macOS under ‘Crash Reports’. That could really help us.

Secondly, can you update your graphics drivers, if updated report which drivers you are using?

Thanks

Hello, I don’t know if a .dmp file was generated when the software crashed. I am using windows 10, where do you store those files? can you tell me the route?

Regarding the graphics drivers, I have the latest version available for my graphics, I have an nvida rtx 2070 maxQ with driver version 516.59.

the crash occurs from the beginning, I open a new project, I include a constant chop and a timer chop and I make a direct reference of the constant value to the legth parameter with the mouse dragging and there is nothing else in the project and the program closes , sometimes it doesn’t even give me the error notice that I uploaded in the first post.

I hope this can help find a solution, if not tell me how I can help.

Thank

The .dmp files will be created in the location the project file is. So just opening a default session would result in them being on the desktop if you haven’t saved the project elsewhere. It is the case sometimes .dmp files are not created.

Well, I don’t think that no .dmp file has been generated. I just tried it again and nothing.

I keep having the bug with 3070ti and latest studio drivers (game drivers had the same issue).
Also, I didn’t find any .dmp file but will look better this evening. I tried to increase TdrDelay first to 8 and then to 16, following this guide:

Also, no change…the bug keep happening, even if I just parm a constant material to a geo with an empty project, or if I reference a keyboard in to any parameter. Funny thing is, if I just write the reference the bug doesn’t occur.

1 Like

We are pretty sure it is in issue in opening the popup (technically a tiny window) which causes a crash. Are your machines laptops? If so, I wonder if its the same bloatware-conflict bug that causes crashes when opening secondary windows as discussed in these posts.

1 Like

hello, in my case it is a razer laptop and from what I have read in the forum that you recommend, you have to uninstall a software that comes with certain brands of laptop. But I don’t have those software on my laptop. So the solution is to delete all the nvida drivers and reinstall them? I still haven’t understood very well but here goes the thing.
thanks

Razer laptops usually do not have bloatware, so it is likely not the problem. It was just a thought as many laptops do have this issue.

I’ve been doing some tests to see if it fixes it. I have uninstalled the nvidia drivers and reinstalled them, this time the studio drivers and everything is the same. gives the same error and the program closes.
I have also tried it on several other computers, an msi laptop with nvidia 1050 graphics and no errors and a non-laptop computer with nvidia gtx 1070 graphics and no errors.

I don’t understand anything that is happening. Does anyone have any ideas or help to fix this?
thanks

Is your Razer laptop a AMD or Intel CPU. There are some challenges with combos using an AMD CPU with integrated graphics alongside a discrete Nvidia GPU. Usually this causes crashes on startup, but maybe there are other effects?
You can read about it here.
https://nvidia.custhelp.com/app/answers/detail/a_id/5182

my razer laptop has an intel iGPU, and although I have investigated where you suggest me in the link, nothing I have found works.
I don’t understand why this problem doesn’t occur with wulkan on other laptops with intel cpu and nvidia gpu. I do not understand the problem.
thanks

Hey!

I’m having the same problem here, even just opening and closing the export movie dialog with the start patch

I’m using a laptop (ASUS Vivobook 14) with a 3050 and the latest drivers (both Nvidia and AMD), I uninstalled Geforce experience and the problem is still here.

I don’t see any other program that could be causing the problem.

Do you have a list of programs that could be considered “bloatware”?

I don’t know what else to try :frowning:

Thanks!

@pitron
Since you have AMD and Nvidia in the same machine, are you tried applying these settings from Nvidia help?

Yeah, I tried that with no luck

1 Like

Hey, can you try setting a Windows Environment variable
TOUCH_ENABLE_NV_AFTERMATH=1
and recreating the crash? This should create a new dump file from the crash that we can look at.

Hello, I have done what you suggest and searched for the crash and it gave me two files, one with the extension gpudmp. But I can’t attach them here. Can I send them to you by mail?

Thank you

yes, feel free to send them to support@derivative.ca, or you can .zip them and post them here.