Crash when i make a reference / The Vulkan Device has returned a fatal error code

I have sent you an email with the generated files, and I also send them here in a zip folder.

dump (3.4 KB)

Hello @cinghio @elihou

Could you please share the specs of your machine? Are you on laptops?

Trying to find out if there is something common for everyone here.


Hi! @JetXS
thanks for the help, I’m on a MSI GE76 with i7 12700H and RTX 3070ti.
I uninstalled basically everything including MSI command center: every now and then making a reference does not cause the crash, but still happening most of the times.

@JetXS no luck?

Hey @cinghio

Apologies on the delay. We are still looking into this issue.

Could you please confirm that your power-saving settings are set to performance? Can you also have a look at what this user recommended here and see if that applies to your case: SOLVED: [Win10][2022.26590] Vulkan crash in very particular MAT + Geometry case - #3 by codrakai


I have tried this solution that you propose and I still have the same crash problem. I have assigned maximum performance in windows and everything you ask. I have also updated to the latest version of Touch Designer and it still happens.
Any solution? I sent you the dump file, have you found any solution?


1 Like

Hello, same problem here

Hi, same problem on WIN 10 Laptop with rtx 2060 and intel CPU

Same problem here on a XMG Core 15 Intel with a RTX360 Laptop GPU, above mentioned solution didnt work out.

A post was merged into an existing topic: Touchdesigner crashes when connecting a line material to a geometry comp

Thank you! - this fixed the issue for me

@pitron, can you confirm the exact model you are using? I’d like to buy one and match what you have exactly.
Is this it?

Hey everyone,

Trying to gather more stats to find if there is a common issue.

@cinghio - could you please share the TD Build number, OS Version, GPU Driver version ?

@pitron - same question as above? + CPU Model ?

@davidmbengue - could you please share OS version / build, TD Build, GPU model, GPU Driver version, CPU Model, laptop or tower ?

@gzzzoga - could you please share the TD Build number, GPU Driver version ? CPU Model ?

@jacobb - could you please share the TD Build number, OS Version, GPU Driver version ? CPU Model ?


The exact model is ASUS M3401q Notebook PC. Seems that that model comes in different configurations. This is the one that I have:
I bought it here in Mexico.

NVIDIA GeForce RTX 3050
512 GB SSD
AMD Ryzen™ 5 5600H Processor
WQXGA (2560 x 1600)

If you need more info just let me know

1 Like

Hi @JetXS,

my data are as follows:

TD Version: 2022.26590
OS: Windows 11 Pro 21H2
Model: XMG Core 15 i7-11800H 2.3GHz
GPU: NVIDIA GeForce RTX 3060 Laptop, Version 516.94 (Latest Update)


Hey @jacobb @pitron

Could you please add the exact GPU Driver version ?

Thanks a lot for sharing those details,


1 Like


Driver version is 516.94

Hello guys,

Same problem here!
It crashes when referencing CHOP.

MSI GS65 Stealth 8SF
Intel(R) Core™ i7-8750H CPU @ 2.20GHz, 2201 Mhz, 6 Core(s), 12 Logical Processor(s)
NVIDIA GeForce RTX 2070 with Max-Q Design.
NVIDIA Studio Driver 516.94
Windows 11 Home Version 10.0.22000 Build 22000

TouchDesigner 2022.26590

Thank you!

Hello everyone, same problem.

Crashing with this error even when opening and closing preferences window.

MSI GF63 Thin 11UD
11th Gen Intel(R) Core™ i5-11400H @ 2.70GHz (12 CPUs), ~2.7GHz
NVIDIA GeForce RTX 3050 Ti Laptop GPU
NVIDIA Studio Driver 516.94
Windows 11 Pro 64-bit (10.0, Build 22000)

TouchDesigner 2022.26590

I went out and got a Vivobook that has a 3050 and an AMD CPU/iGPU. I’m able to reproduce the issue with 516.94, however it does not occur with 512.95. So that may be helpful for some people. Still looking into this though.