Crash when i make a reference / The Vulkan Device has returned a fatal error code

Hello, I’m trying the version of the nvida driver that you have recommended (512.95), and for now it gives me no crashes and everything works fine.
It may be a solution, but I’ll keep testing.

I have a razer laptop intel i7-8750H cpu and nvida rtx 2070 maxQ gpu.

in case it can help someone. Thanks and I’ll keep trying.

3 Likes

Thanks, reverting to 512.95 fixed it for me too.

3 Likes

reverted to 512.95.
It helped.

2 Likes

Reverting to 512.96 works for me as well

1 Like

Just adding that I was getting the same error with nvidia drivers 516.40
The error also happened on 517.48
It is working correctly when reverting back to 512.96

Microsoft Windows 10 Home
11th Gen Intel(R) Core™ i7-11800H @ 2.30GHz
NVIDIA GeForce RTX 3060 Laptop GPU

Touchdesigner 2022.28040

1 Like

Hey!

Any news about this bug? Reverting to 512.95 reduced immensely the number of crashes but I still have crashes from time to time.

I don’t know if the dmp files are still useful to you guys :slight_smile:

so how does one actually revert to 512?

The crashes are probably something else if you switched back the drivers so sending dmp files to support would still be helpful.

1 Like

You can just run them like normal and select “Perform Clean Install” in the options you see in the driver installer dialog. You can also ‘uninstall’ them from add remove programs, but I find the clean install much faster and reliable.

1 Like

Ah! I see thank you!

Hey I’m getting some TD Computers set up for a couple-week-long gig and just wanted to try to head this off at the pass…

Are these issues only related to computers with an integrated AMD GPU in addition to NVIDIA dedicated? Or is this even related to just anything with an AMD CPU in it as well…

I started up TD 2022.28040 on Windows 10 Pro 21H2 running NVIDIA Game Ready Driver version 522.25 (on an RTX 3070 with AMD Ryzen 9 CPU) and couldn’t recreate any crashes as described above, so does that mean I’m good or would it be recommended to stay with 512.26 Studio Driver just in case…

Hey @pexel

The mix we had noticed after gathering info from everyone seemed to be Integrated GPU w/ NVidia GPU.

If you are not running these projects on laptops you should be safe overall, unless you have a desktop setup where you make use of an iGPU as well as a dedicated GPU.

Not quite sure if any change made it to 522.25 which would have an impact on this isssue, but we also have a tentative fix coming in TD in the next couple weeks.

Best,
Michel

1 Like

Cool, It’s a desktop and I’m 85% sure I disabled the AMD iGPU in the BIOS or something (I’ll double check) but yeah I’m only using the NVIDIA GPU and it’s DisplayPort / HDMI Outputs.

There’s one laptop for possible use on this show, but I might just avoid using it out of an abundance of caution as I’m going to lock-in 28040 as this show’s version after today if I can’t stress test it into crashing.

1 Like

Hi, any news on this? I’m encountering the same problem and reverting doesn’t help.

I’m on RTX 2070 super…

Hey @sintj - did you update to the latest version of TouchDesigner ? What build are you running ?

@JetXS The latest, downloaded this morning! (sorry for double posting, don’t know what happened)

So you have the latest version of TouchDesigner installed, not the latest NVidia drivers since you reverted though? And the bug is still occurring?

Can you please share the complete specs of the machine ? Is it a laptop or a desktop?

If you go back to the latest Nvidia drivers, is the bug still occurring?

@JetXS Tested on both old drivers and latest ones. I’m on desktop with a 2070 super, Ryzen 5600, 16 GB Ram and Windows 11. I’m trying to pass in a Multi GLSL TOP a 100x100 crop repetition to use it as a sampler, but when i connect it after the first one (fit1 in the screenshot) it crashes.

This may be a different bug, can you post your .toe file? It’s potentially an issue with the GLSL code in that node.