Downloading previous TD versions

Hello everybody!
I’m a lighting designer and I’d like to start using it :slight_smile:

But…I have a mid 2014 Macbook Pro with Yosemite (version 10.10.5).
Can you tell me which TB version I could download to make it work? I could not fin the information inside the archive.
I wouldn’t like to update the system version since my computer is already a bit old. I can’t afford have troubles with other softwares that I usually need for working.

Thanks!
Skrycky

Sorry, TouchDesigner was never compatible with macOS versions that old.
If you go here: https://derivative.ca/download/archive
2019 and earlier builds worked with minimum requirements of 10.11
2020 builds require 10.12

I personally have a much older Macbook Pro (2012) and would highly recommend moving to macOS 10.12 Sierra, it is so much better than 10.10 and has a lot of important upgrades. I didn’t find much if any software that stopped running in Sierra, they kept very good compatibility.

This years 10.15 Catalina you DO need to be careful, a lot of old software will not work as they dropped 32-bit support. I currently run 10.14 Mojave on my 2012 Macbook Pro because of that, but 10.14 is more resource intensive than previous builds. The sweet spot is probably 10.13 High Sierra, but I would consider 10.12 minimum to use.