DPI scaling in 099?

Hi everyone,

I just upgraded to 099 from 088 educational. The entire interface looks scaled and aliased. Is it yet another Windows high DPI UI scaling issue? Or is this because I went from an educational license to a non-commercial licence? I thought only the resolution of the media was affected, not the interface…

I already tried disabling the UI scaling in the properties of the .exe file, but to no avail.

Thanks all!
LP

If you have DPI scaling turn on for Windows, then TouchDesigner will use that same DPI scale level. The method we use right now isn’t perfect though, as we are rendering at a lower resolution and scaling up. Native higher DPI rendering will come later. Your license won’t affect the UI quality one way or another, so that’s not it.

That’s really odd, since I have installed 088 and 099 concurrently and only 099 displays UI scaling. Is there a setting to make it work like 088?

It’s a feature that was added in 099, since previously people were having to set their high DPI monitors to low resolution to make things visible. There is no setting right now to revert it back. We could add one if there was enough demand for it.

I’d really appreciate if there were a flag to disable it. For now I have to change the scaling for the entire OS, which means that I need to logout every time I want to use TD 099. I’d upgrade in a snap if this were not the case.

The way you have it implemented right now is that the “disable display scaling on high DPI settings” option in the .exe’s properties does nothing.

Thanks for your help.

Could you give us a screengrab of what you are seeing? If you set Windows Scaling to 100% it will work just like 088.

Hi,
I’ve added screenshots of both 088 and 099. You can appreciate the scaling on 099.

Setting DPI scaling in Windows for the entire Windows session does work, but it scales everything, and requires a logout. With my current settings, all my other software looks fine, including TD 088, but not TD 099.

Thanks for looking into it.
088.jpg
099.jpg

  • 1 for this!! To be honest I was pretty disappointed to see 099 still having this issue :frowning:

It’s very clear that the blurry scaling up method is not a solution. I’d rather turn off this function as changing the scaling setting on Windows every time I use TD is pain.

Any news on this? I’m also having this issue… Really doesn’t make a lot of fun to work with TD on my laptop at 125% scaling.

Would appreciate some update, thanks.

I remember thinking it was fixed in a later version or TD. Although it might coincide with me getting a bigger monitor.

This year’s Official build will fix this as the UI rendering engine has been completely overhauled. It is currently being beta testing in experimental, though we do not recommend switching to experimental yet for any production work as its too early.

Thanks a lot for the update Ben! These are great news, looking forward to the build.