ENTTEC DMX USB Pro mk2 connects to Mac but not PC, in a dramatic reversal

As described in the title, I’ve got an ENTTEC DMX USB Pro mk2. When I plug it into my Mac the status light flashes green/white/green and TD sees it. I can control an RGBA light from TD.

When I plug the ENTTEC into my PC, the same TD file does not recognise the device.

I don’t think I need any drivers to connect to this— I don’t see references to drivers on the enttec site or here.

I’ve tried different USB ports etc.

Is there a trick to this?

dmx.tox (4.2 KB)

Do other programs see and control the EntTec on the PC? What does it show up as in Device Manager? There are other device drivers that could try to load for the EntTec (that are not EntTec and thus would prevent it from being used as a DMX output) possibly from some past thing you plugged into your PC at some point causing some other very similar drivers to get loaded / associated with the EntTec by Windows.

If you can figure out which Device Manager entry it is tied to, you could try uninstalling and deleting the drivers from Device Manager and then restarting and plugging in anew.

Yes, you need the serial port emulator in some versions/installs of Windows (intel chipset, mostly). On their website.