Export movie dialogue says "file not found"

Hi everyone,

unfortunately there is a bug when I export my movie via “export movie dialogue” . When it finished I want to open the movie file via “view” but it says “File is not found”. I checked it a lot of times, but it doesn’t work and the file is not found.

I tried it with MPEG 4 (Part 2) and with H264 (NVIDIA GPU). I need it in 1920x1080.

I also tried it with different versions of Touchdesigner (2019.19160 and 2020.24520).
This made no difference.

Has anyone an idea how to fix this? What else could I do to get this movie?

Thanks a lot and have a nice and sunny saturday,
Verena

Could you update to the latest build 2020.25380? There was an issue where the movie files were not being closed, therefore they would not play until TouchDesigner was closed. But build 2020.25380 has this fixed.

Thanks for your answer.

I tried what you said with Version 2020.25380, but export movie dialogue still says: File not found.

In the meantime I tried to use the movie file out instead, but here there was the problem with the limited resolution with the free version of Touchdesigner. I was so desperate last days that I bought the educational version to finish my exams.

But with the new educational version 2020. 25380 both export options are not possible: neither to get an export via movie file out with H 264, nor to use the movie export dialogue, it still says: File not found.
So I really don’t know what to do now. Do you have another idea?
:thinking:

It says: NVIDIA H 264 is not supported on this OS. I use a Macbook pro Retina, Mojave 10.14.6

Thanks for the information regarding your system, that shows the issue. H265 and H265 encoding require a Nvidia GPU, and thus Windows OS with Nvidia.

You should pick another codec and try that. If you need H264 for your final, I recommend selecting Animation codec to go out of TouchDesigner with no quality loss, then re-encode in another software like Quicktime. Note that Animation Codec is heavy, so if you use the Movie File Out TOP you need to turn off the realtime flag. The Export Movie dialog does this for you so you don’t need to work about it.

After recording, find the movie file in Finder and launch it in VLC or Quicktime (Quicktime will not support all codecs).

If you are interested, the list of features that requires a Nvidia GPU, or Windows OS, or other specific system are all listed here: https://docs.derivative.ca/System_Requirements

thanks a lot for helping and explaining!

I am not sure if I understood you in the right way, but unfortunately the “movie dialogue export” still does not work. It still says “The file is not found”. Not in the finder or anywhere else.
(I prefer using the “movie dialogue export”, instead of the “movie file out-export”, especially with not working H 264 on my system).

So what can I do to use the “export movie dialogue”?

When does it say “Movie File not found”? When you click View?
A screengrab might help.
All 'View" is doing is trying to open the movie to preview, so I meant you can locate the file in Finder and load it into TouchDesigner or play it back in VLC to see if your recording worked.

Here is a screenshot. I used the educational version 2020.25380, and I did not use the H 264 but the MPEG 4 in export movie dialogue, but it is always the same: File not found, as you can see here. Some months ago it was no problem to export movies via export movie dialogue, even with the free version of Touchdesigner. I could always find my files where I saved them while exporting.
What else can I do, maybe I do anything wrong without knowing? But strange that it worked months ago.
Hm…

Remove the space in the file name, and always include the file extension, ie .mov
The “View file” button will likely not work if there is no file extension.

When does it say “no file found”? When you click “View”? I asked this previously as I need instructions to reproduce it here. Everything works with properly named files on my end (filename.mov)

I did not type the space myself in the file name, it happens automatically after naming it, for example test.mov. Maybe this is the mistake, I don’t know why this happens. My names and the place I want to store it are changed by computer or Touchdesigner when I write them down, and I don’t know why. I know that space is not good in names on computer :wink:
After I am told that “export finished” in the line at the top (next to where realtime is) I click on “View” in the “export movie dialogue” to see the file. But I cannot find the file nowhere on my computer, with clicking “view” or without clicking “view” - it doesn’t matter.