External Editor Delete from Disk Bug

Windows 10, TD 2019.15840, VS Code as editor, 1.34.0

It seems when I try to edit multiple python scripts, the one I opened later will show “deleted from disk” as soon as I open it. And I won’t be able to save any changes into the one that says “deleted from disk.”

This happens when I open multiple instances of TD, and try to edit scripts from each of the opened projects as well.

I am not sure if this is a bug specifically to VS Code. I tried to replicate it with my Atom install. But for some reason, TD is refusing to open atom as an external editor.

We were not able to reproduce this with VS Code, the other editor we tried is Sublime, also no issues. We don’t delete the file while TouchDesigner is open, and we use the same name for the temporary file during the session (unless you change the file extension).

The files should be in $TEMP/touchtmp/ named something like dat*processid#.py. Do you still see them in the directory? Do you have read write access in the directory? Can you try Admin access to see if there is a difference? Can you open the files directly from Explorer with VS Code?

What error do you get when you specify Atom as your editor?

I will collect these info for you tonight.

Thank you.

Hi Selina,

so, apparently, the delete from disk bug has gone away after a reboot. I think it might’ve had something to do me running out of temp space? Though, I did have at least 30gb on that drive. So, I think this bug can be marked as resolved.

As far as the Atom bug, please see attached screenshot. I think this bug might have something to do with way Atom starts. I checked the Windows desktop shortcut for launching Atom. It points to an executable, but it had a different “start in” directory. I tried to use the binary inside of the “start in” directory, but still the same error.

Do you guys have any issues with the Atom editor?

Thank you.
Atom Error.png

We don’t have any issue with using Atom. Here’s the path we use:

C:\Users\XXX\AppData\Local\atom\atom.exe

Hmm… that’s odd. Maybe I will try to reinstall my Atom install instead.

Thanks.

Any luck with your Atom re-installation?