Feedback re: new zoom method in 40k builds vs 20k

I’d like to offer some (hopefully) constructive criticism regarding the new zoom method in Designer Mode in the 40k builds.

Issue: the new zoom mode causes me to get often lost in the limbo land between two zoom levels. This slows me down and/or confuses me.

After some more testing of the same file in 2020.28110 and 2020.45290 I believe I have found the root cause of this - so I prepped an example with steps how to reproduce my problem, for all of you to try in 20k build and in 40k build, instructions are in the network.

Behold, the famous Zoom Challenge , 20K vs 40K !
Would love to hear what other people experience.
Also tagging @ben and @snaut, thoughts?

the_zoom_challenge_20K_vs_40K.toe (4.1 KB)

2 Likes

I have some trouble as well but will check your example before commenting, thanks for putting this together.

sorry for my ignorance, novice here truing to learn,
what is actually the difference between 20k and 40k build ? is it to do with resolution ?
cheers

@emykat it is the difference between official releases of TouchDesigner (which have buildnumbers in the 20.000 range) and TouchDesigner experimental releases (which have buildnumbers in the 40.000 range).

The first change was to allow to get in closer to panels-only when Viewer Active is on (to operate mid-size panels). That’s 7 clicks before it drops in. (I was falling into the sub-network too easily and getting pissed off)

It was also changed so that everything else (all other node types or Viewer Active Off) you could zoom into more before it fell into the sub-network (again I was falling into the sub-network too easily and getting pissed off). That is 4 clicks now. So yes, it’s personal preference, and depends on your physical screen size and how many panes you have and whether TD is full-monitor. Time for a big vote. But don’t get hung up on what you are used to. Perhaps should be in Preferences.

1 Like

Personally, I only use U and I to nav in and out of nodes. For me its faster and i like that it doesnt change the viewport. I get frustrated sometimes zooming too close to a node to see something (panel, large dat…etc) and accidently zoom too far and go into the next node.

What you describe definitely is affected by screensize, so thats not fair to all users to change without making it adjustable in Preferences. Also if its adjustable, i would love to just be able to turn zoom off :slight_smile:

+1 for exposing this in Preferences

Actually, you can already disable this zooming behaviour (zooming in and out of operators) in the preferences, it’s under Network tab, “Mouse-wheel Navigation”

This post was flagged by the community and is temporarily hidden.