FIXED: 2019.33020 and 2019.19160 Win 10 - glitches with uniform fields on GLSL TOP

Hello,

Encountering various glitches when deleting the name of a uniform on a glsl TOP, resulting in the value field getting disabled, and clicking on that value field at the same time.
Only way to fix it is to restart TD.

See this video : https://drive.google.com/open?id=1dvs_UyZe9oPBbHbw85iopESo-9kGCnZ3

Maybe a very easy fix would be to not disable the value fields, which would also be consistent with the GLSL MAT?

Thank you!

1 Like

+1, would be nice to have the old way of setting the values in a glsl TOP (similar like the MAT not disabling the inputs)

Hi @vinz99

This bug is confirmed and logged… Basically you are getting stuck in the disabled field and only way to get out of it and regain control is to do a undo via Ctrl+z

Best
Markus

Thanks Markus! Good to know for Ctrl+z, didn’t think of trying it.

ha - yeah - I got stuck in this as well and hadn’t saved in a while so tried everything I could to regain control :slight_smile:

Ha I wasn’t as thorough since when I tried to quit it let me save the file.
Incidentally, a similar state happens sometimes using the value ladders (middle click gets stuck), couldn’t never reproduce 100%, but same it lets me save when I quit.

The disable issue with the value ladder should be fixed. I fixed a similar thing with the middle click value ladder as well, not quite sure if it is the same one you encountered. Thanks for the bug report!

2019.19960+

1 Like