FIXED: 2020.20625 win10/mac FieldCOMP problem if first row is empty

Weird behavior of cursor if the first line is empty. Up and down keys stops changing cursor position. And if the field has several empty lines in the beginning, mouse click ignore this lines.

Thanks for the report, we’ll look into this.

Hi Ben! I found another bug in FieldCOMP. If you enter non ASCII characters (in my case, i tested Russian), field comp randomly separate character to the new row. This issue happen only in the first 8 rows, after it working properly. Thanks!

The first line empty bug should be fixed in the newest build.

I cannot reproduce the second bug with limited Japanese and unfortunately don’t know any Russian! Can you reproduce this issue with copy/paste strings in Russian, and can you give me some examples to try?

Thanks for the report.

Yes, sure. Mac_os_unicode_problem.tox (1.3 KB)

On Windows this problem was fixed, but on mac os it still remain.
For test i using this string.
“”"
ТачДизайнер. Проблема с юникодом.

ТачДизайнер Перескакивает на новую строку.
“”"

The .tox you attached, when you load it up are the newlines stil embedded in the Field COMP? Do you get the newline issue when you copy and paste the text? What version of macOS are you running?

Thanks!

Yes, i saved this tox after recording my screen. And yes, when i copy another Russian text, i have the same issue.
Right now i am working on 10.12.6 Sierra, and i also tested on 10.15.3, the same problem.

I’m on 10.14.6 and cannot reproduce, similar for a colleague. We both have Nvidia GPUs. So the .tox loads up like the attached for us. If I copy & paste the text from the DAT into the Field, I get the same. I switched my keyboard to Russian as well to try, but from what you are saying your copy & paste will give you unexpected newlines.

What kind of GPU does your mac have?

Also Nvidia, 650M. I reopened tox, it shows all right, but if i a create new or copy it, the bug appears again. And in every instance, error is different.

Yesterday i noticed another issue with Keyboard in DAT on mac. By holding cmd it doesn’t updates the same key event twice or more. I don’t know, do i need to create a new topic with this bug?

No need to create a second bug, I’m happy to continue on this one.

Regarding the russian text issue. I’m not able to reproduce what you had exactly, but I found that when I deleted characters in your second work newlines are added, so I can take a look there and see what is going on.

With the Keyboard In DAT, it only monitors up and down state of keys and has always worked that way. I did notice that when I held down a key while the Field COMP has focus I do not get multiples of the same character appearing. So I’ll look into that issue. Normally I would expect the panel value key & character for a Field COMP to change multiple times while a key is being held down. I think this changed happened with the macOS implementation of unicode.

The extra newlines appearing when deleting non-english text will be fixed in the new builds of 2020.20000 and 2020.40000 we post. Thanks for the report and great sample!

So apple appeared to have change key repeats default to allow choosing accented characters instead of repeating characters. Preferences -> Keyboard -> Key Repeat seems to be ignored. If you go to Terminal and type in

defaults write -g ApplePressAndHoldEnabled -bool false

That’ll change disable the accent popup and enable key repeats. Applications need to be restarted for it to take place.