FIXED: Can't connect to all inputs of Base COMP

using build 2023.11340

I’ve made a Base COMP and in it I have a script that creates ‘in TOPs’ and for some reason I can’t plug TOPs into all of the inputs of the Base. I’ve tried setting the ‘connect order’:

..(runs within a for loop)
in_nodes[ x ].par.connectorder = x
..

if I do ..= x +1 then i can connect a few more inputs than before, but only if I connect them in a certain order(?).
if i don’t give the inputs any ‘connect order’ I can only connect to every second input.
I feel like this is a bug, but i could be missing something, but I’m going TOP to TOP so I don’t see the problem.

Any help, if possible, would be appreciated!

Hey @Clabbe

I looked into this and I am not sure I am following everything you are doing.

We’ll need an example file to try and replicate.

I was able, so far, to connect every individual input after creating n inputs from a script.

Best,
Michel

Multi_Screen.tox (3.3 KB)

Try this tox.
Its preconfigured to 6 inputs.
I tried it in a seperate scene and found that i could only connect to input 1,2,4,6, after that i could connect to input 3 and 5.
if i then delete all the input nodes and create a another TOP node that i connect to the inputs they all connect fine. i can only repeat the bug by deleting the tox and dragging in a new one.
the order of accepted inputs seem to change depending in what TOP i try to connect.

Thanks for digging on this one with me!

When you say connect inputs, do you mean

  • manually by dragging a TOP output to one of the Multi_Screen ?
  • or using python to connect a TOP A to an Input n?

Best,
Michel

Manually dragging: from output to input.
I’ve to yet to come to that stage in my code, maybe it would be better to reference the nodes i want by name and just let the script connect the inputs.

Can you capture a video ? there is no issue on my end.

Arguably your code is too Python involved and could be done with the new Sequence parameters and / or a Replicator, or a combination of both.

You could also look into the Splitter COMP in the palette which might be what you are after.

Best,
Michel

here i’m only having trouble with input one, until i switch them around.

Is your timeline paused ? Is the realtime flag turned off?

Are you on windows or MacOS?
are you using a mouse or a trackpad?

Timeline and realtime are on. Win11. Mousepad.

Hi,

One of our developer was able to reproduce and this is logged to be investigated further.

Best,
Michel

Thats great to hear, I guess!
And thanks for the advice on the replicator!

Best regards.

Thanks for the report and finding this rather obscure bug. This will be fixed in the next build. For a work around you could let go of the mouse when you see a wire appear to the input you want to connect while you are dragging near it. Or alternatively, click select the output and then click select the input instead of a mouse down drag.

1 Like