FIXED: Engine COMP and Kinect (Azure)

My Build:
2020.24520
My Machine:
Lenovo P53 with Windows 10 Pro
Quadro RTX 3000
Intel Core i7 vPro 9th Gen

I am experimenting with the Engine COMP which is one of the most exciting developments in TD for me, but I have an issue with running information from Kinects inside it.

When I run the .tox [KINECT_TOX_PROJECT] on a regular instance it works just fine, but as soon as I load it into an Engine COMP inside another project [KINECT_ENGINE_PROJECT] it somehow renders everything in a weird manner, as if it could not read the whole range of the sensors.

I have locked the OP’s in case that you have no Kinect Azure nearby :slight_smile:

https://we.tl/t-TTKOSl4wg2

We’ll take a look and get back to you.

Discovered the Engine COMP is not properly passing in 32-bit float texture data which is why all your points are in the wrong position. We’ll work on a fix, thanks for the report!

2 Likes

Is it the same if you are getting only chop data? I get the some really lagging behaviour when I try to use engine comp and just get the data from 2 kinects azure.

CHOP data inside Engine COMPS is not supported afaik, maybe it got changed during the recent updates, but the last time I tried it did not work

CHOPs are fully supported in Engine COMP.

@gabriel.ciobanu we need more info to understand your problem. Which build are you running and could you share your .tox?

1 Like

@arctor023 I forgot to get back to reporting in this thread that the 32-bit float issue was fixed a while ago. If you grab 2021.10330 this is working.

2 Likes

Yes this is the Tox I use as an engine comp and the data that comes from kinect are very choppy. Another issue that I am curently having that data from kinect azure just freezes from time to time but TOP data is still running. I am using latest build 2020.
Pc build intel i9 2.8 ghz 32 gb ram 2080ti 8 gbvram

Kinect.tox (16.4 KB)

I am also following this exact issue. Thank you

@gabriel.ciobanu How does the component work for you when it is running just in the project and not in an Engine COMP? Are there any differences in the performance you see? I see the exact same behavior when your Kinect.tox is simply loaded into a session as when it is loaded into an Engine COMP.

As for freezing/drop outs, are you using the Kinect Azure supplied cable USB-C cable? Many USB-C cables are not up to the task as they are not all rated for the same data throughput. I have seen cables and certain port on a computer very often being the problem for instability in the Kinect data stream. Just want to remove all the variables when troubleshooting this with you.