FIXED: Engine Comp License Error - TouchDesigner099.2019.30550

Sometimes when loading toxes into the Engine Comp, a touchdesigner error appears :

’ Error: An error occurred determining the installed license (/enginecomp)’

The system has a Pro license installed. Sometimes the tox seems to be working properly, sometimes it doesn’t appear to work correctly.

This installation of touch is running from an extracted folder - would that have any influence on this?

TouchDesigner099.2019.30550 on Win10 64Bit

Setting the clock parameter to ‘Synchronized’ always has this issue on this system, setting the clock parameter to ‘Independent’ still produces the error but the tox seems to work correctly most of the time regardless of the error.

me too.
Even though I have a pro license, but it doesn’t work at all.

Build: 2019.30790
Windows: 18362.329
HP Z840, Nvidia Quadro P5000.

thank you,

Hopefully this is an issue with the older version of TouchEngine in your primary installation of TouchDesigner.

If you follow the steps to force the experimental build to be used, does the issue go away?

Hey, can you also try setting a windows environment variable TOUCH_LICENSE_ERRORS=1 and try out the latest experimental. This should give error messagebox’s for licensing when engine starts, which will hopefully help us narrow this down.

Hi Malcolm, thanks for working through it with me.

After setting that environment variable, on the first TouchDesigner launch I got a popup with the name ‘V7’ with the text ‘No such file or directory’ .

Thanks @pointshader - I think we’ve identified the problem based on that popup. Working on a fix.

1 Like

@bangnoise Thanks for looking into it! Any luck figuring this out?

Yep - fixed in the next experimental build.


Great, thank you so much! Is there a loose ETA on the next experimental drop? Looking to incorporate this into development asap.

About a week or so from now, towards the end of next week. I know you know this, but it bears repeating, careful using Experimental for projects right now, its very… er… experimental!


Thank you for the time estimate, @ben .

For me this issue is not fixed. I just tried 2019.37030 (on Windows 10) and still get the Error “An error occured determining the installed lincense”. The path to the engine_path is correct…

Sorry to hear this @django - two things to check:

  1. Could you verify you aren’t running TouchDesigner as an administrator - navigate to the TouchDesigner installation you are using (if it’s the default installation then probably at C:\Program Files\Derivative\TouchDesigner) and right-click on TouchDesigner099.exe and select Properties, and on the Compatibility tab make sure ‘Run this program as an administrator’ is not checked.

  2. Try Malcolm’s instructions above for setting the windows environment variable TOUCH_LICENSE_ERRORS=1 and report back on any pop-up errors you get.


hi bangnoise,

I am not running Touch as admin and have set the environment variable, but do not get a pop-up error.
Is there anything else I could try?


I should add, that I am using a non-commercial at the moment, as soon as I got my license back I will try it again.

Ah that solves it - currently TouchEngine requires a paid license. The error reporting could definitely be clearer, I’m fixing that. Sorry for the confusion.

@bangnoise, Curious to know what you mean - is TouchEngine planned to only work for paid licenses? Or will this be opened up to non-com eventually? I have a pro license, but am wondering if something I author with TouchEngine will work the same for non-com licensed users.


Currently we only plan to enable the Engine COMP for paid licenses. This can always change in the future but for now that’s the plan.
Can you elaborate on what you mean by ‘author with TouchEngine’ though?

Ah, thanks for clarifying @malcolm - My goal was to offload some heavy tasks in GeoPix to separate threads / Engine Comps, things that need to be constantly recached in the background, custom light culling, etc. It sounds like for anyone using GeoPix in non-com, those engine comps would simply not load their TOX?

If that’s not possible, I imagine I can find some other solutions to that problem that might be a bit messier, python multi threading I have read some stuff on? but haven’t tried, also launching another Touch instance that runs in the background might be an option, but slightly more confusing to the user if they accidentally close it and don’t know why certain things stop working etc.