FIXED: FaceTrack CHOP - "file could not be found" error

Its creating the mesh, I downloaded the files, put it on the same place and run a command terminal with the writed line but no success…

FaceTrack.38.toe (21.0 KB)

This is a work-in-progress test file for the Face Track CHOP only. Try this first. There are 3 parts:

On the right are stars at the face track points.

Bottom left a rectangle that follows the head tx, ty, rz.

Top left is example of moving your head to look on either side of a scene with an approximation of depth.

Please excuse the inelegance of the calculations.

Hello Greg,
I tried your .toe but it doesnt work “failed to lod features…”
I tried also to use the command prompt to create the nvf file but it also failed:
It indicate the file “sfm_shape_3448.bin” cannot be opened.
All the indicated file are in the same folder as "Convert…Model.exe
What is wrong?

G:\TD\face>ConvertSurreyFaceModel.exe --shape=path/sfm_shape_3448.bin --blend_shape=path/expression_blendshapes_3448.bin --topology=path/sfm_3448_edge_topology.json --contours=path/sfm_model_contours.json --ibug=path/ibug_to_sfm.txt --out=output-path/face_model0.nvf
“path/sfm_shape_3448.bin”: The file could not be opened
ConvertSurreyFaceModel [flags]
where flags are:
–verbose[={true|false}] produce verbose output
–debug[={true|false}] write extra debugging information
–shape=<file.bin>|<file.nvf> specify the input EOS shape file
–blend_shapes=<file.bin> specify the input EOS blend shape file
–topology=<file.json> specify the input EOS topology file
–contours=<file.json> specify the input EOS contours file
–ibug=<file.txt> specify the input EOS ibug mapping file
–in= specify the input file *.nvf
–out= specify the output file *.nvf or *.json
–recompute_topology[={true|false}] recompute the topology
ERROR: The file could not be opened

Finaly I was able to generate the .nvf file, suppressing all the “path/” in the text from the wiki.
But is no more working…
Trying to update to the last build?
still no success (RTX3090)
here is the working prompt
ConvertSurreyFaceModel.exe --shape=sfm_shape_3448.bin --blend_shape=expression_blendshapes_3448.bin --topology=sfm_3448_edge_topology.json --contours=sfm_model_contours.json --ibug=ibug_to_sfm.txt --out=face_model0.nvf

Sorry for the confusion, I just copied those instructions from the Nvidia documentation. Path was just meant as a placeholder to whatever location those files are in. If they are in the same folder as the exe then you should just list the filename. I’ll update the docs to try and make that clearer.

We’re still looking into the “failed to load features” issue. So far it seems to be working on the machines that we have here available to test, so I’m not sure what the problem is.

As a separate note, we did just identify a problem with the 126 pt landmark mode that we’re fixing at the moment (there appear to be some incompatibility with the landmark feature settings and mesh fitting that we’ll need to add some warnings for).

Just noting that I got the same error on my machine

This is on an RTX 3080. I may test later on other computers and will update if I have a different result.

Thanks for the report. It looks like there is an issue with the 30xx generation cards that we’ve been able to reproduce here now.

For some reason they behave differently than the 20xx card that we’d been mostly testing on. Looking for more details on it now.


Hi guys, i’ve tried to make work on my machine the last face track chop… i did firstly all the steps, (nothing is worked for me) and after i’ve asked help using other face_model0.nvf from other users… in this case too no way…

my configuration is the amd 5950x and 3090… latest cuda installed, ar sdk installed.


  1. test with the default model path (error - failed to load feature: the file could not be found)

  2. test deleting the model path
    (error trasfering image: some parameters are not appropriately matched)

A quick update for everyone: Nvidia just release an update for their face tracking system (now part of Nvidia Maxine) which seems to fix the “file not found” issue that was happening on 30xx series cards. We’ve still got a few things to finish testing with the update, but I’ll post an unofficial build you can try as soon as its ready.

1 Like

Super! waiting for it. Thank you.

Here’s the new update: Dropbox - File Deleted

It uses the new 0.7.5 release of Nvidia’s AR library which seems to work properly now on our 30xx series test system. As with other unofficial builds, this hasn’t gone through our regular testing procedure, so there may be other issues.

Let me know if you run into any problems.


I really really appreciate it. Thank you. With 2021.12569, FaceTrack CHOP works with RTX3090, win10, NVIDIA driver version 461.92.
(and it did not work with NVIDIA driver version 457.51)

SUCCESS! works great on my Win10, RTX3070, Driver version 461.92

1 Like

For me it works also now, only odd thing is it drops out when I disable the viewer active on the Face Track CHOP, but I really like this new feature :slight_smile:

Glad its working.

I don’t think the Face Track SOP is forcing the CHOP to cook at the moment, so if you’re not using any of the CHOP’s channels (or have the viewer off) it likely won’t update. I’ll get that fixed in the next update.

1 Like

@robmc Thanks a lot, it works now. Only begining to test it.

Downloaded and installed this version (i’ve 3090rtx)… the chop works, but when i connect the sop, face track chop give me this error:

P.s. i’ve checked all the buttons but nothing change.

Unfortunately, that error message is coming from the nvidia library and doesn’t really say much about what the actual problem is. That is the point where it is trying to load the TensorRT (TRT) ai model.

Possibly try an absolute path to your mesh file. Since nvidia is loading that file internally, sometimes the base path it is using is not the same as TouchDesigners.

You mentioned installing the cuda and ar SDKs - have you updated your graphics driver as well?

1 Like

all is updated… i’ll do other test in next days… thanks anyway :slight_smile:

ok. I’d definitely recommend trying it with an absolute path to the mesh file i.e. c:\program files\derivative\ …\meshfile.nvf I get the same error message you were seeing when trying with a relative path

Let me know if you’re still having issues.

1 Like