FIXED: NDI In Top not working on High Bandwidth setting?


Im trying to use the NDI In TOP and for some reason it only works on Low Bandwidth mode. Is this a common issue?
Manually setting the Search IP also yields no results.

TD 2018.25850
BirdDog Ndi device

Thanks very much!

You’re running an older version of TD - can you try updating to the current official release?
NDI got some updates in recent versions of TD.

I can confirm its also an issue in the latest commercial official build as well.

Moved to bugs forum, we’ll look into it.

Amazing Ben! Thanks

I think it doesn’t work only for interlaced sources. I’ve checked many resolutions and framerates and NDI In TOP is working perfectly with progressive formats. So there must be a bug in ndi receive code - NDIlib_video_framev2_t structure has property named “allow_video_fields”…

We specifically have that set to false right now, so NDI should be only providing use with progressive frames and doing the de-interlacing for us.

Sorry for using an old thread, but this still seems to be an issue when using interlaced NDI sources. Any chance this could be fixed?

Version: [2019.18360 ; Win64]
Steps to reproduce
*Select interlaced NDI input
–>Video is not shown, but audio is received
*Select Low bandwidth option
–>Video (and audio) is received (much lower quality)

When receiving an interlaced source, the info CHOP is indicating a growing number of received_frames that seems to correlate with the fps of the NDI source. Could the problem be that, unlike the MOVIE IN or VIDEO STREAM IN TOPs, there currently is no deinterlace option for the NDI IN TOP? If so, then could this option be added?

Thanks for the report and sorry for the delay in fixing this. This will be fixed in the next build we post. 2019.19030 or later