FIXED: NotchLC + Video Device Out (GPU Direct) issues

I have encountered error when outputting NotchLC video to Video Device Out with GPU Direct transfer mode. I am using Blackmagic as output device. When I activate output, NotchLC decoding either stops, or Video Device Out TOP produces error Failed to setup GPU Direct. Try changing the Transfer Mode parameter. When using Asynchronous transfer mode (or different video codec) everything works as expected (tested on Win 10, TD 2020.22080, Desktop Video 11.5, NVIDIA driver 442.74).

Best wishes


1 Like

Thanks for this report, we’ll look into it.

If you put another node between the two, such as a Resolution TOP or a Level TOP with default settings, does that allow it to work?

Thanks for reply. No, putting another TOP in between doesn’t help. (This happens even on a large scene with many TOPs in between those two.)

Thanks for the report. This should be fixed in the next build we post.

1 Like

@monty_python Would love to hear if this is fixed for you in the newly posted 2020.23680

All right, I will try it as soon as possible and let you know. Thanks.

Hello, I have done some tests with NotchLC in TOP-heavy scene (including multiple video outputs using nvidia direct) and it worked as expected. :slight_smile: Thanks.

1 Like