FIXED: Perform Mode (no borders) persist over Designer Mode after Esc

Hi!

macOS Catalina 10.15
Touchdesigner 099 build 2019.19160

How to reproduce:

  1. open Touchdesigner with default project (jelly beans)
  2. go to root level and select perform node (window COMP)
  3. put “Borders” parameter to OFF and “Always on Top” ON. Check if “Close on Escape Key” is ON
  4. press F1 to enter Perform Mode
  5. Check if window has focus and press ESC to exit Perform Mode

I expect that TD returns to Designer Mode but now I see a jelly beans frozen OVER Designer Mode which is still running behind that. E.g.: if I click on upper left corner of jelly beans frame, TD open page in browser because behind jelly beans frozen frame there is the WIKI button.

I can shift again to Perform mode and return to Designer Mode but nothing happens (still jelly beans frozen).

With parameter “Borders” ON this no happens and all works fine.

Can you help me?
Thanks so much!

Thanks for this report. I think I have fixed this issue, although the fix requires quite a bit of testing. The fix may or may not make it into the next build we plan to post soon. If it doesn’t, it’ll be in the one afterwards.

Hi @suppanaico
We have posted a fix in build 2019.36500, but we need to confirm it works. Would you mind trying and let us know if it solved the issue for you?

You can download that build here: https://derivative.ca/release/201936500#toDownload