FIXED:Spammed with unknown midi messages

I have a strange midi bug. My console is at irregular intervals fully spammed with unknown midi messages.

I don’t know where they come from, i tried it with different midi devices and different touchdesigner versions but nothing changes.

It’s not just the spam in my console, it also triggers midi inputs in my midi map.
Not to mention the lags, if 20 such messages come in at one stroke.

I tested my midi inputs with a midi monitor, everything is running correctly.
I tested everything on my second pc, it works fine there.
I think there are compatibility problems with my new amd cpu
My system runs with an amd ryzen 9 5900x, are there any compatibility problems?

I would be happy to receive an answer

Omg, I’m having the same issue. I thought I notized that for the first time a week ago, and I would’ve sworn it wasnt present before. I haven’t updated Touch. But I DID do Windows Updates. Could that be the problem? I’ve tried this on 2 different Intel systems, and it occurs on both of them (one running an i7, one running an i5). I’m accusing Windows Updates here.

It occurs on both builds 2020.23680 and 2021.10330
I’m on Windows 10 Pro 2004 19041.867 on both systems.

Okay, I have now done some further testing on this. System:

Intel Core i7-8700K
nVidia GTX1080TI

TD Build 2021.10330
Windows 10 Pro 2004 19041.867

Here’s what I’ve found:

  1. The MIDI Bursts come in intervals of about 10-15 minutes.
  2. The problem doesn’t occur in a NEW (!), blank project.
  3. The problem seems to occur after a Midi OUT CHOP with a corresponding MIDI Map has been present in the Project. After that, the problem still occurs even after deleting the MIDI Map and the MIDI Out CHOP, essentially going back to a blank project.
  4. The problem also occurs when closing bespoke Project. Sometimes it also happens on opening it, but I haven’t found any regularity to this.

I couldn’t reproduce the problem by using MIDI-In only, but I’m using a MIDI-Loopback here, so it might also occur when setting up a MIDI-Controller like you did.

I am not alone with this bug :smiley: but there is no help from touchdesigner, that disappoints me very much.
I have this problem all the time, is very extreme. Now i have to connect the midi in to another pc with touchdesigner. From there i send the data to the main pc via a touch out. Yes i know that is completely complicated. But there is no other way.
Funnily enough, i have no problems on the second pc.
Both pc are on the newest Windows 10 Version

I use extensively midi on Windows (intel i7 and ryzen 7) and macos and never had this problem.
I would look at two things:

  • I never use midi map, I map the device with their proper editor and I use straight midi in
  • the E-J Lightning screen capture show note off burst. On some midi controler and editor, you have it to be sure that all not are off. It seems some device in your midi network is sending a constant note off.

I never had that problem, only on my new pc and that’s really weird.
why not use midi map? it always worked for me
i made two videos:

on one you can see midi in spam

on the other you can see how the midi map is triggered even though no input is received

that should not be.

To be precise, I don’t use MIDI Maps, but I have to create the devices in the MIDI Device mapper, don’t I? So I create the devices and use MIDI-Out CHOPs triggered via Python to send the MIDI-Messages.

TD is sending out CC121 on all channels according to Cubase’s MIDI-Monitor. I have checked every device in the network, these are definitely coming from TD. I now use a pretty weird workaround by sending MIDI to Bome MIDI Translator Pro and “swallowing” CC121 from the MIDI-Stream coming from TD, which solved the problem for me for now. (this also shows that it’s clearly coming from TD).

Also, my patch (which is a touchscreen-controller for Cubase) hasn’t changed since about a year, and the problem just appeared a few weeks ago. Same PC, same TD version, same patch. I only updated Windows.

Sorry the the delay @btf, we can’t get to all reports immediately.

@EJ-Lighting thanks for being so specific about your Windows version - strange that it only happened after any update. As a note, there is a newer update available 19042.868 released on 3/18.

Could either of you send over your projects that do this so we might more easily recreate a setup that reproduces the issue (we’ll have to get lucky it seams and test on a number of systems). If you don’t want to share your files publicly please send them to our support by email.


Hi @ben, sorry for the late reply, got a lot on my plate atm. Attached is a project file which produced the problem. midiproblem.toe (108.1 KB)

edit: I’ve just tried it with the latest Win update, and it’s still doing it :confused:

Thanks for the file, we will look into it.

Hi. Just wanted to check if you found something.

It is registered but has not percolated to the top of the list yet. Thanks for your patience.

1 Like

The project file just contains a MIDI Out CHOP, and a text DAT and locked TOP.
Was anything removed from the file, or was it just adding those 3 that causes the
intermittent messages to come through?

Another question, how long is your timeline set to ?
The MIDI Out CHOP can be set to automatically output note-off events each time it loops around, or is manually rewound, but in the small MIDI file you sent those options seem to be turned off.

Hi Rob!

I opened TD, and then created an entirely new Project file. So the project was completely empty. I then set my MidiView as the output port for Device ID #1 in the MIDI Device Mapper. Then, I added the midioutchop and waited, and it started sending those messages in irregular intervals. I then took a screenshot of my MidiView, put it in a moviefileintop and locked it. That’s it. I just re-opened the project and it’s still behaving like that… What’s confusing is that it’s still doing it, even if you remove the midioutchop. As soon as a midioutchop has been in the project, it’s gonna send out these messages.

My timeline is set to the standard 600 frames length.

Thanks for the extra info. I’ll keep digging.

1 Like

Alright, I believe it’s coming from a different MIDI Out CHOP inside: /local/midi/template/mapmaster1
Can you navigate to that folder and either turn off its Active Flag and/or Disable Automatic Note Offs?

It was sending Note Off events at the wrong times in some cases.
This is fixed in the next build, but you can turn it off in that location for now.

Hope that’s it!



Thanks alot, that seems to solve it! In another project, where I had the same issue, I also had to deactivate Auto Note Offs in other parts of the patch, e.g.:


Just for your reference. Btw, it’s still sending out Note Offs when closing or opening the patch… that’s not really a problem for me, but being able to turn that off would be great. Thanks so much again for your help! :slight_smile:

Glad we finally found the problem.
The next posted build will fix those semi-random Note Offs.
If not please let us know.