FIXED: Touchdesigner freezes when choosing Player Index - Kinect Azure

Hello, I have a problem with the TOP Kinect Azure and TOP Kinect Azure Select. My firmware is updated and all other options of Image work(Color, Depth, Ir, Point Cloud), but when I choose Player Index. The program freezes completely.

I have a good PC, intel i9, RTX 3090, etc. Do you know what can be the problem? Thanks.

Solved until today I share the answer from Derivative.

Sorry you’re having problems. I believe the issue is with the body tracking AI used in the Player Index mode and your RTX card. If you check out this thread on the Microsoft Azure github, there are a lot of people with 30XX generation cards having problems: https://github.com/microsoft/Azure-Kinect-Sensor-SDK/issues/1125

Microsoft originally said they were going to release an update last October/November to address this, but unfortunately that never happened. According to the last post in the thread, they’re now saying middle of next month (february I guess). Once Microsoft’s update is out, we’ll have to update TouchDesigner to the new version, but that shouldn’t take very long.

cheers,

1 Like

Thanks for following up @cardelluis, we’ll update this thread once there is a fix from Microsoft available as well.

2 Likes

Hi. Are there any news on this? I am delivering a project with 4 interactive screens with 2 Azure connected in a row and kinect data just freezes from time to time or when I switch cooking on some containers from the project. Specs are rtx 2080 // intel i9 // Touch build from May.
I do not want to use the latest build because it has a problem with Touchplayer (it says invalid window format) and it won’t just do for an autoplay set-up.

You’re issue is unrelated to the original posters report, this problem is only with 30-series Nvidia GPUs.
Have you tried using the most up to date 2020 build? We recommend using 2020.28110 which has months of improvements over the May build, including a number of Kinect Azure updates. It also does not have the TouchPlayer issue you refer to in 2021 (which will be fixed in the next build we post btw).
If you switch to using 2020.28110 and it still crashes (seems stable here) please send us a dump file.

1 Like

hey guys it seems like Microsoft has finally released a bug fix for RTX 30 series, any chance we could have a quick adaptation into TD?
I’ve purchased a RTX3060 for my installation setup, not realizing it is currently not supported. Would be great if I could use an update instead of downgrading it to 20 series. Many thanks!!

1 Like

Hi there,

Just tested the new SDK (on a 3090) and seems to work using the shipped viewer. TD still gives a warning (doesn’t crash anymore) about cuda not being found. I think it’s because the new SDK uses cuda 11.1 and 11.0 is used in TD. Is there an easy way to update the cuda version ourselves or is this something Derivative needs to do for the next (experimental) TD version?

Cheers,
tim

I downloaded the new azure sdk on friday and just got started looking at it. We are working on getting it into touch asap. It’s mostly an issue of distribution and making sure we’ve got all of the necessary cuda libraries for all of our various nodes that need them. The new kinect sdk is 1GB larger than the previous version and we don’t really want to double our installer size.

Unfortunately, I don’t think you’ll be able to manually update the cuda version because of those checks that were put in place to avoid the crash.

I’ll let you know when we have more info.

2 Likes

I’ve updated TD to the new Kinect SDK if anybody wants to try it out. Unfortunately, I don’t have a 30xx card at the moment to try it out on, so let me know if there are any problems.

2 Likes

Unfortunately no data in the CHOP or the Player Index TOP, still showing the Ampere not supported error on both. I’m available if you’d like me to run any debug etc commands for testing on a 3090 and am fluent in python etc.

Thanks for the feedback, I guess there must be an additional check somewhere that it is hitting. I’ll take another look and get back to you.

Hi @robmc, great you are looking into it! Available here as well to test. We have a couple 3090s in the office and can report back after your fixes :slight_smile:

Thanks @Darien.Brito

I’ve removed the cuda version checks from the Kinect Azure CHOP and the Kinect Azure Select CHOP as well, so hopefully everything will work with this version:

Hi there,
what a timing! Learned about the problem an hour ago,
and can confirm that it works with 2021.11920 (win10, 64bit, GTX3070)
Thank you,
best
Stefan

Great! Thanks for the feedback. We are working towards an official update within the next week or two that will include these changes.

2 Likes

Can confirm here all working as well! Thanks a lot @robmc :smiley:
2021.11920
(win 10, RTX3060, RTX3090)

1 Like

2021.12360 is now posted if you want to move up to a ‘full release’ build.

Not sure if that is still relevant, but in 2021.11920
OSC reception does not work

Are you still having issues with the new official release (12380) or was it just that test build? Did you allow TD network permissions in your firewall? Each version generally needs a separate exception.

For testing reasons I had the firewall turned off.
However, the problem is not there in 12380 : )

1 Like