FPS lock on brand new laptop

Hey there, so I just finally bought my new laptop for Touchdesigner, the Razer Blade 14 2021 (RTX 3070 version), which I’m super happy with, it’s just an awesome device.

Now I was running Touchdesigner on my external monitor (a Dell HD 60hz), that went completely smooth. But when I tried using Touchdesigner on my laptop screen, I’m instantly getting a 30 FPS lock, on a blank new project. I tried multiple things, for example windows interface scaling, different frame rate settings, AMD integrated GPU drivers update, but that didn’t seemed to do anything.

Now I’m wondering, could it be because this laptop is a 165hz 1440p monitor? Which would be an odd case since the power in this laptop, and I was expecting it to run normally. I’m running the latest AAA games on highest settings, so I guess there is nothing wrong with the laptop itself.

Would love to know if this is an issue with Touchdesigner or maybe with Razer Blade, because then I would consider a different laptop, since the whole reason I bought this laptop was to use Touch on the laptop screen for live visuals.

Laptop specs:

  • AMD Ryzen™ 9 5900HX
  • 14-inch QHD 165Hz, 2560 x 1440
  • NVIDIA® GeForce RTX™ 3070 (8GB VRAM)
  • 16GB DDR4-3200MHz

This can happen when the GPU fights vsyncing between your external and internal monitors, or switching between integrated and discrete GPUs. I would suggest going into your Nvidia GPU settings and turning Vertical Sync = Off. This will let things run freely. If you need Vsync during Perform Mode, you can turn it on explicitly in the settings of the Window COMP you are using.

@ben
Hey Ben, thanks for your reply!

I tried turning off the Vsync setting, but nothing seem to be different in Touchdesigner. Still a lock on 31 FPS

Can you check with the Monitors DAT which GPU is reportedly working for each display. I wonder if its some issue with GPU switching, we don’t have much experience yet witht he AMD intergrated GPU and Nvidia GPU, but its often a problem in Intel/Nvidia Optimus systems as well.

You will want to try to set TouchDesigner to always is the discrete Nvidia GPU. There are settings for this in Windows 10 under Graphic Adaptor and also in the Nvidia Control panel where you can ‘force’ the GPU instead of letting it auto-select. You should also check the BIOS to see if you can force it. Let us know if you find anything.

@ben
When opening the monitor DAT on my internal monitor it says that it’s using the AMD intergrated graphics.

I’ve tried setting the dedicated GPU to Nvidea card for Touch both in Nvidea control panel as well as windows graphic adaptor, but still no luck in the FPS change. Also after rebooting the laptop.
I still need to try the BIOS setting, but I’m wondering, will I be able to set the GPU for Touch specifically or will it change it for the whole laptop?

@ben

The battery power of this laptop seemed to be the issue. When running Touchdesigner with the power connected and the graphic settings on high performance it all seemed to work fine. And as you described in another post about a similar issue, the monitor DAT still shows the AMD gpu, while the work is actually being done on the Nvidea GPU.

I guess using Touchdesigner on battery power on a heavy gpu like this, is just not possible?

Thanks for the help :wink:

But after some testing again, it is still odd that I’m getting quite some FPS drops on a simple feedback TOP network, when I open the perform window on my external screen, when running Touch on my laptop screen. I’m getting 46 FPS max, while the nvidea gpu hangs at 64% and the processor at 10%. The AMD gpu hangs at 10%.

This wouldn’t ofcourse be usefull when using this setup for live generative visuals on a projector.

Could there be another problem for that?

I have a similar laptop, last years basically, and was going to say - you gotta be plugged in! Battery power doesnt let you use your real gpu. Then turn up all the Windows level settings in Power and Sleep settings to max.

1 Like

Yeah that certainly helped when using it only on my laptop screen.

When I’m using Touchdesigner only on my internal laptop monitor, or only on my second monitor, it all works fine. But whenever I want to use touchdesigner on my laptop screen and a perform window on my second monitor or vice versa, it all goes down and it’s start using the processor intergrated graphics again.

Is there any possible solution to this? Because it is the main reason why I have purchased this laptop, to use it for live visuals being projected on a second screen.

I wonder, since its a new machine and maybe now is least painful, have you tried installing a fresh install of Windows 10. Without all the crap that most laptops have pre-installed, its a chance to get everything back to bone-stock, and correctly install the right drivers and software, no surprises. Anyways, its the first thing I do with any Windows machine I receive, as crazy as it is.

Did you ever find a solution to this? I’m considering buying the same laptop primarily for sending visuals to an external display as well.

Hey, I have done a full windows reset, and the issue of an instant frame drop to 30 FPS seems to be resolved now. I sometimes still have some frame drops when using windows COMP separate window mode on my second screen, while running Touch network on my laptop screen. But this seems to be caused by the usage of the network editor, and I think that a proper VJ setup will resolve that.

Thanks @ben for the help, much appreciated!

After running some tests, with a semi intense TOP feedback loop. I have found that running several instances of the same visual, on my external screen, didn’t had any effect on the frame rate. I could run it to my monitor’s default refresh rate limit (165hz), on a constant 165 FPS.

But when I drag the same project window to my laptop, the frame rate drops to 80 FPS. This could never be my processors internal GPU, because it would be to heavy for that processor.

Next to that, while running Touch on my Laptop screen and outputting the COMP to my external screen, had also an effect on the frame rate.

Which is still quite odd, since it shouldn’t be much heavier, right?

Could this be an issue with the interface scaling, that doesn’t work well on my laptop screen? I have double checked the battery and performance settings. Or maybe something else that I’m missing here.
Because a strange thing is that when I run Touchdesigner on my external monitor, and project the visual to my beamer/projector, it has less frame drops.

This is likely vertical sync fighting between the monitors. If you go into Nvidia settings and turn the “Vertical Sync” to OFF under 3D settings, this should get around that. Note that Window COMPs also have a vertical sync setting but you said project window so I don’t think that applies here.