GPU Driver not recognized

I am on Windows 11 with a Geforce ti 3070 for laptops and I am using version 2022.28040. When i try to start touchdesigner it tells me i need at least driver version 472.47 for my pc. That version doesn’rt even run on windows 11 anymore. I tried downgrading my gpu driver, tried different versions of touchdesigner. Nothing seems to work.

1 Like

Getting the same message today when trying to start 2022 or 2023 versions, 2021 version starts. Laptop with AMD Ryzen and Nvidia 3070. Nvidia drivers version 531.68.
Yesterday all worked well. But it seems that in the evening there was some windows update…

I’ve checked with Asus Armoury Crate and confirmed with Windows Task Manager that TD starts on the dedicated graphics card. So somehow TD now fails to detect that Nvidia drivers are recent and well beyound the minimal version.

Some info:
OS: Windows 11 Home, 10.0.22621 Build 22621
CPU: Ryzen 9 6900HS with Radeon Graphics
GPU: Nvidia 3070 ti
Nvidia Driver version: tried with 531.68 and now with 551.23

Just to let people know. For me restoring the system to the restore point created automatically yesterday fixed the problem. I don’t know which exact updates were auto installed (checking windows update history does not show that anything was in fact installed) but in my System Restore two recovery points were created yesterday. I restored to the earliest point.

Hi @Joel_DM

Make sure that all your drivers are up to date, including integrated graphic drivers if any.

Look around for bloatwares as well.

@dancing_pixels What sometimes happen on Asus laptops is that the Asus Control Center will update the AMD drivers to OEM drivers.

Run AMD Adrenalin minimal installer to make sure this is using the latest driver.

In Armory Crate, make sure you are in Standard Or Ultimate GPU mode to force the Nvidia GPU to be enabled. Optimized mode will disable / enable the Nvidia driver on the fly, which is causing issues.

Just ran our latest version on an Asus laptop fully up to date and didn’t encounter issues.

1 Like

We’re trying to reproduce here but no luck so far. Are you using the preview version of Windows 11 by chance?

I’m using a laptop with an AMD Radeon integrated GPU and dedicated nvidia gpu. The solution was to deactivate the integrated GPU.

https://nvidia.custhelp.com/app/answers/detail/a_id/5182