Hello all,

I’m trying to use a GrandMa2, as output

But it’s not as plug and play then with the enttek, anyway succes? and can share the procedure

Thank you

try using the Art-Net, and describe your questions further may also help.


I did try to have ArtNet, config my console for it, like back in the days, try like describe in here, so I put a dmx out and a ArtNet in touch, find where to put some of the data, like subnet and all, but I most be missing some step, because it was not working.

for example, basically as a test run,I just want to have a LED Par, connect to my MA2, and from the touchdesigner, with something simple, like a constant and a math of 255, open the dimmer channel of that Par.

Thank you

You are trying to do a data merge in the console. Usually HTP (highest-value takes precedence.

Begin by setting up your artnet output in touch. If you want to, use a second insurance on another computer with a dmx-in node to verify that you are outputting data.

Next you need to set up the desk to accept the input. In setup, under network protocols under artnet you’ll have to change the ‘requested’ field I think to ‘input’ or ‘input and output’ and make sure your universe start, amount and offset values are matched.

This is about where my knowledge of the MA2 runs out. The process and the particulars of setting up the MA to merge artnet and output DMX is something you should ask on the MA Facebook group or the ma-share forums.

It sounds like you’re using a $20k lighting console as essentially a DMX adaptor. While this is broadly amusing, there is probably a more elegant solution. Hopefully the console is serving other purposes on your show. :slight_smile:

Alright I got it, first you should understand that as a console, the grandMA2 is considering itself as a DMX output device rather than taking DMX signals from Art-Net and pass them though.

Here’s what you should do as a test run:
1.Patch the LED being tested.

2.Light up the LED,store it as a cue to a fader.

3.Goto Setup(by pressing the Setup KEY),find the Remote input setup in the first page.

4.To the third tab named DMXRemote,add a remote input and set the type to executor and assign a DMX address which will be used to control desired fader.

5.Exit this page and goto the network page,go into the network protocol page and activate the Art-Net input by clicking the button to the right, then add a new data entry and set mode to Input.

6.Send a DMX signal in TouchDesigner via Art-Net with the correct DMX universe and address you previously set in the DMX remote tab.

That should solve your problem.

Here’s some screenshots to the settings,sure you can find your way out.


Not to resurrect an old thread, but because this was linked to, I figured I should mention that you CAN also directly control fixtures through a GrandMA2 rather than just triggering executors that have pre-recorded sequences in them.

All you need to do is set up the Art-Net input as described above, and then, if the fixture has an external Intensity Channel, make sure the GrandMA2 has said intensity channels to full, but the MixColor values set to zero (you can record this RGB “black” into an executor) so that TouchDesigner’s RGB values will “shine through”.

You may also need to check that “DMX In Merge” is set to “HTP” and not “Off” in the DMX List view that you access from LiveSetup mode AKA “Patch only (Live)” in the setup menu.

If everything is working, you should see white values show up in the DMX Sheet and the word “Art” show up on the corresponding tile of the “Universes” Pool.
If (like in the above example) you do not have the DMX Out CHOP’s channels lined up properly, you will see white values appearing in unpatched DMX channels in the DMX sheet. Simply add or remove empty channels (at zero, using a Constant CHOP for example) to get your channels to line up with how the MA2 is patched.

@Peeet What should the network and local address of the DMX Out CHOP be set to? I heard in another MA tutorial that MA just listens for any Art-Net on any address but I can’t seem to get it to work. Any insight would be appreciated!

If you’re running MA2 OnPC, make all of your ip addresses be in the 2.*.*.* range or 10.*.*.* range with a subnet mask of

If you’re running MA2 OnPC on the same computer as TouchDesigner, you can do the same as above, but you have to do it on a LoopBack adapter - and I’m not talking about because I believe that MA software only looks for Art-Net in IP addresses with 2. or 10. starting octets.

On Windows there should be a built in “driver” that you can install to create a LoopBack Adapter. I think these might be the best instructions for Windows 10, but if not, just search around for something like “Microsoft KM-Test Loopback Adapter”:

Then, set it’s IP address to a 2. or 10. and then restart OnPC (with that adapter selected under Setup>MA Network Control) and TouchDesigner with that IP in both the network and local address parameters.

If it’s going between two computers, both IPs need to be in the 2. or 10. range (but different) and then local address would be the IP of the TouchDesigner Computer and Network Address would be the MA2 OnPC.

@WAMSAY Please note that Local Address parameter is only for your system if it has multiple network connections and you need to specify which one to use. You can read about this in the DMX Out CHOP help.

@Peeet I was trying to get it to work on the same machine so the LoopBack adapter was definitely my issue. Thank you so much clarify! It’s working great now :slight_smile: