Helios DAC Issues

Thank you folks! First off, it is a little more resistant to dropout compared to Ether Dream v1, I guess because the buffer is able to hold more data. Looks nice, in general, but I did encounter some issues.

Here is a small example toe: https://github.com/tgreiser/helios-touchdesigner/tree/master/Shapes_Example

  1. Green Scale - does this work for other people? For me it doesn’t scale, just all or nothing, cutoff around .25. I see the same thing with Ether Dream CHOP, so maybe it is just my projector.

  2. Intensity Scale - no effect to any color, causes warnings if I adjust it.

  3. In general it seems like adjusting any of the parameters causes Helios buffer write failures and I see:
    warning - Queue full. Try increasing queue size.
    (increasing the queue size does nothing but generate more warnings)

In a complex project like laser juice, this warning flashes approx every other frame even when I don’t adjust the Helios CHOP params.

  1. Seems like something odd is going on with performance, it can’t manage 60 fps, even in the example. Seems about 8 fps slower compared to ether dream CHOP in every test I have tried (ie, ether dream runs around 58 fps, helios runs around 50 fps max).

When testing in Laser Juice, I get about 45 fps in design mode with no laser flicker, but if I go into perform mode with Helios, performance drops to 15 fps and it starts flickering like crazy.

The top graph shows perform mode and the laser is dropping out like crazy. Output LED is flashing several times a second.

helios_chop_perform_mode.png

Bottom graph shows design mode but everything else the same - getting warnings about a full queue, but laser has no dropout or glitches.

helios_chop_design_mode.png

I’ve only used the etherdream so beware the peanut gallery over here. However:

Green scale works for me just fine (3w rgb Lightspace), but if my incoming points are at 100% brightness, the individual colors of the laser cut off under 5% (0.05 on the slider). Not sure if it’s a hardware safeguard or issue.

Just a quick check, are you running the helios on it’s on own port? (or for that matter, I’d try to have it on it’s own bridge if possible).

Probably just my projector then.

Yes, I tried various ports and unplugged my USB soundcard.

I did additional testing in Laser Juice, I made a fresh start and actually got it working pretty well. However, this time as soon as I turn the Helios active=off the framerate drops to about 7-10 fps. The same project file without the Helios CHOP has no problems, Ether Dream CHOP runs steady 60 fps. If I just use the bypass flag and not active param, then Helios CHOP is working. Still kind of a mystery to me what is causing this different behavior.

64-Bit Build 2017.10000 - Windows 10

Here are my revised issues:

  1. Intensity Scale - no effect to any color, causes warnings if I adjust it.

  2. In some workflows, (scenario A) framerate drops in performance mode when Helios DAC is active (this happens in the Shapes Example, but not enough to cause dropout). In other workflows (scenario B), turning Helios DAC inactive results in a major performance drop (in both modes). Not clear what triggers each scenario, have not seen both at the same time, always seems to be one or another.

Odd/Nuisance:
3. In general it seems like adjusting any of the parameters causes Helios buffer write failures and I see: “warning - Queue full. Try increasing queue size.”
(increasing the queue size does nothing but generate more warnings). Doesn’t actually seem to have any negative effect except maybe wasting cycles.

Here is a good example of scenario A. This should be a very simple test, a single point that moves around. I get a small amount of dropout in design model, a ton of dropout in perform mode. By comparison, Ether Dream CHOP has no dropout.
HeliosTest.3.toe (12.5 KB)

Not sure how to re-create scenario B yet. I can provide the Laser Juice test or perfmon dump via email if needed.

Hi Tim,

thanks for reporting this. We can see that the Helios starts flickering after a short while plugged into the usb port. It becomes stable again when replugging it - so we have a starting point for instigating.

Regarding the Intensity - I just found this thread here: photonlexicon.com/forums/sh … LDA-pinout saying that

and

So it is most likely not used in the projector.
Best
Markus

Thanks Markus, I did a test integration with Laser Juice and I see the flicker even when things are running at 60 fps. I see there is a helios_dac release within the past 2 weeks and it looks like new firmware and driver.

Is upgrading the driver as simple as dropping the new DLL in TouchDesigner\bin? Otherwise I think we need to know what Helios SDK version is installed so we can pair the correct firmware, no?

We’re currently testing some changes to the Helios DAC that will make it much more tolerable to frame drops and FPS settings.
It will also incorporate the latest SDK version v6.

But one thing to note, I see your file uses trails to fix the sample length to some number of samples.
This will work if TouchDesigner does not drop frames, but better it to keep everything timesliced, (so its variable length) which the next Helios DAC CHOP will handle appropriately.

Cheers,
Rob.

Build 2017.11520 is posted now if you want to try it out.

The issues previously mentioned are now fixed. Most of my relatively non-interactive examples are now working well. I do still get flicker and the helios shows points dropped and a queue adjusted when I try to make interactivity.

helios-scan.toe (6.67 KB)

Scenario 1: You can see the issue in this example. Just feeding the LFO through the TUIK slider results in the flicker and odd queue behavior.

Scenario 2: If you bypass the TUIK slider and just go from the LFO to the Null, then the flicker problem stops.

Scenario 3: If you use the TD UI and a mouse to change the parameters in the Transform SOP, then you see the same issue as Scenario 1. Points get dropped as long as you are using the mouse/UI. As soon as you release the mouse button, then the signal stabilizes.

Hey everyone.
Cant find batter discussion to ask this questions.
Сan someone tells me is it possible to create fade between two colors for one line? via helios or eather dream chop?

And one more question. Is it possible to do mapping (like stoner for ‘top’) if I am using ‘sop’ with scan chop? For example to merge 2 lasers.

I will be grateful for any help