How can I keep the channels in the OSC In CHOP correctly?

Hi, everyone!
I made a program that performs osc communication between python programs, but these programs have a problem as follows.
Two int values as two channels are communicated. For a while, the channels in OSC In CHOP (receiver side) are kept at two.
When communication is started and left, the number of channels of OSC In CHOP (receiver side) starts to increase due to unknown reasons.
Please see the following figure.

How can I keep the channels in the OSC In CHOP correctly?

The OSC In is coming from the OSC Out that’s there? Are you able to share this .toe file? Seems like a bug if the OSC In is generated lots of channels from an OSC Out that only has two.

1 Like

Thank you for the reply!

Yes, it is.
This is my program.

SimpleTest_share.toe (4.0 KB)

This bug is occurring because the ‘Send Rate’ parameter is turned off for the OSC Out CHOP. You can avoid the bug by turning that parameter back on for now. We’ll look into fixing the issue though.

1 Like

Thanks a lot!!!
Thanks to you, I can fix my trouble!!!