How to write to csv file using file out dat

I would like to get the volume waveform data and convert that data to CSV format and retrieve it.
However, it seems that file out dat can only be converted to .dat or .txt.
I could not successfully extract the exported .txt file as a csv.
Doesn’t it support CSV format export yet?
Or is there a technique for writing it out that neatly keeps the rows and columns?

If you feed a table DAT to the fileout DAT you can save as CSV - you just have to change your file extension.

Thank you for your response!
I was able to confirm that it can be expanded as a csv when I did file out dat from table dat.

However, I couldn’t do what I wanted to do because I don’t know how to convert from chop to dat to table dat.
Do I need to write a script?
fileout_csv.toe (16.3 KB)

Take a look at this example - you just need to change the file extension to csv on the fileout DAT. You can then pulse the Write File parameter to write that csv to disk.

mr-edit-fileout_csv.toe (16.3 KB)

It’s done! Cheers!

I was mistaken that the common > edit extension should be changed to csv.
Thank you so much for your prompt response.

Reviving Super old thread, but am I not sure if I am missing something super obvious or it’s possibly a bug.

I want to save my tables as CSV

I got table >> fileout (with extension as CSV)
Yet when I bring it in with filein you can see it’s missing the columns. When I open the file in a text editor I can see it’s missing comas too.

Am I missing anything?

Thanks again!

Hmmm - interesting. I’m getting the same result. This might be worth moving to bugs - or posting there as well.

Sorry to revive the old thread but found some interesting behavior and thought it would be useful to share.

Similar to tellart if I save via the “Write File” button on the I get tab delineated values.
If however I call “op(‘fileout1’).save(‘data.csv’)” from a script I get comma delineated values.

Might be useful to anyone who comes across this thread with the same issue as I did.
–Hank

Thanks Hank, running save() from a script worked for me as well. It seems the “Write File” button is not working properly.

I have an additional question. I checked my saved csv file and the delimiter was tab. Is there any way to change the delimiter to a comma?

mhank above mentioned that if you use the python command to save out then it is comma separated.

Thanks for letting me know.
Sorry, it was written just right above. I had overlooked it.

1 Like

Let me know of that still works and is a success for you.