Intel d435 RealSense TOP - Fails to init

I recently got a d435 to test out. I installed 2016 R3 SDK/Runtime (version 11) to match my version of TD as stated in the Installing RealSense Software for Windows SDK instructions. Sample programs work and I am able to get both the color and depth streams. However, when I open TD and create a new RealSense TOP, all I get is an error: “Failed to initialize the Intel RealSense cross platform api”. The d435 sensor is, however, recognized by the TOP. I have tried uninstalling/reinstalling the SDK numerous times and additionally tried the most up to date SDK from Intel. Any ideas as to what could be the issue when attempting to use the d435 in TD?

For making the Intel RealSense D435 working you don’t need to install a SDK. Assuming you’re using Usb 3 already (because Usb 2 doesn’t work well with newer realsense devices), sometimes changing the Usb ports helps as I had the same issue and when I tried PCI-USB 3 expansion card on my PC, the issue got resolved. Although it doesn’t have to be a PCI expansion card, some USB 3.1 ports work better for me than the others.

1 Like