Intel NUC8i7HVK GPU issue


please may I ask whether developers or anyone else have access to Intel NUC8i7HVK? I have been fighting rather strange behavior of GPU on this nuc for several months. I can’t seem to solve this and it somehow seems to me like issue related to Touchdesigner (however I am not sure about that).

GPU used in this nuc is Radeon RX Vega M GH. It works like expected, but when it comes to using Touchdesigner, it does not perform very well. Problem is that GPU Core Clock is fluctuating when using Touchdesigner and therefore it does not have enough power to keep steady framerate. It is dropping frames even though it does have enough power to run just fine.

Touchdesigner sometimes makes it utilize full Core Clock speed (1190MHz as it should) and then it works perfect. However getting to the state when it runs properly is like being defined by non-deterministic random (sice it happens only sometimes and is not related to anything I could possibly think of). When this happens, it could run whole days just right - without ever dropping single frame. Once restarted, it gets back to “bad” behavior - and constantly changes Core Clock when using Touchdesigner - therefore dropping frames.

I have been testing this with 3 different Intel NUC8i7HVK and all of them behaved the same. During last year I have gone trough multiple versions of BIOS and its configurations, multiple versions of GPU drivers and their configurations, several Windows and Touchdesigner updates, but none of them made a difference.

Other graphics related software makes this GPU utilize full Core Clock speed without any issue. For example when running UNIGINE benchmarks it works just fine every time - using 1190Mhz and therefore getting the most out of it.

Please does anyone know what might cause behavior? Thanks in advance.
I am currently using Windows 10 1903, BIOS 0058, AMD Radeon 18.12.2, Touchdesigner 2019.18580. I am attaching screenshot from GPU-Z showing Core Clock when runnging Touchdesigner in perform mode.

i have more than few at work,
will try to check.

what you use it for ?

Thank you very much barakooda. I wanted to use this nuc as small and portable “content generator” with touchdesigner (since it is powerful enough and yet small to be placed basically anywhere - even when there is not enough space).

I will have to wait a bit for update the TOUCH099 licenses
but my results are fine:

win10 pro 1903
AMD driver version : 26.20.13001.50005 ( get the latest from amd site, not intel )
Touch099 version : 17550
Bios : 058

once will get the updates will update the results.

Thank you very much for testing it. Please could you try using also perform mode?

Also thank you very much for recommendation on using driver from AMD site. I tried it but result is the same.
I am attaching video that shows how it behaves. (I am sorry for “handheld quality”, but performing actual screen recording would alter the results in this scenario.) If touchdesigner is running, core clock is high enough to perform well and not drop frames (even though sometimes it drops frame, but it is no big deal in this case). I am just guessing that Touchdesigner UI might make gpu raise its core clock high enough (it mostly sticks to 1190Mhz). However once I enable perform mode, gpu core clock lowers and frames start to drop heavily. (11.9 MB)

Tried with perform mode and such…
All good on my side.

Thanks for testing it. Hmm, interesting. Please would it be possible to send you scene used in last video so you could test it on your setup?

make it simple please.

Great, thank you very much.
I am attaching the scene. I have removed everything unnecessary to make it simple. However it became too “light” so I added set of level TOPs to make it “gpu heavy” enough to drop frames constantly. I am also sending video used in this scene, but as long as you have some HAP-Q 1920x1080 25fps footage, feel free to use that instead.
Thanks once again.

P.S. With this particular scene I could get only about 48-55 fps due to low core clock. Funny thing is that once I double the amount of level TOPs, it becomes “heavy” enough to make core clock stick to 1190Mhz and not drop a single frame.
test_60fps.4.toe (6.35 KB)

Hello barakooda,

please have you managed to run that scene on your nuc? Thanks.

@monty_python you can get someone’s attention in the new forum using @ infront of their name. Like this… @barakooda

Sorry, I will try to check in the next week or so.

So cool ! :slight_smile:

@ben Great, thanks for info.
@barakooda No problem, thank you very much :slight_smile:

yo mate,
I have the nuc here again , but cant download your scene.
if still relevant, I can now do the check.

Hello :slight_smile:
Thanks for looking into this. Is it a problem with downloading the scene itself (which was uploaded uploaded directly to forum), or just with hap-q video (which was uploaded to wetransfer)? I guess it is just problem with video since wetransfer package is no longer available. I will re-upload some hap-q video as soon as I get to computer.

I have reuploaded video, feel free to download it here:

few drops per minute, seem fine.
i guess when pressing print screen or initiate gpu z it drop bit more.
you can look on the time on the bottom right of the images. (612.5 KB)

I don’t get it :smiley: How is that possible :grimacing: I could see that your gpu core clock is high enough and seems stable. In my case it fluctuates heavily and drops much more frames. Could you please try it one more time after shutting down nuc and unplugging it from power?

Works fine,
Maybe its your hard drive or gpu ,hardware etc…

Hmm, I don’t know what might cause this, but I believe hard drive is working just fine. I thought it might be some hardware problem with GPU, but it seems unlikely since I have tried two other NUC’s (same specs) which performed the same way.
Anyway thank you very much for your help.