Intel RealSense

I was at Intel’s Los Angeles DevLab/Hackathon for RealSense last week and got to take home one of the DevKits. Touch can access the depth camera feed directly with VideoDeviceIn TOP. Here’s a little demo of what I figured out during the hackathon (after failing to sort out receiving tracking data from Processing and changing directions… port binding follies)

When it came time to present our hack-jobs, I pitched mine as interactive signage for storefronts and special event brand activation ( and won the grand prize! No C# required! :smiley: The demo video is running on the computer I won: Lenovo Yoga 2 Pro with 2GHz i7, 8GB RAM Intel HD Graphics 4400. Touch runs surprisingly smoothly on this laptop/tablet hybrid machine.

I’m eager to use the actual tracking data eventually, but the depth cam alone is pretty cool for now. The SDK demos (backdrop removal, facial expression tracking, etc) are pretty cool and lead me to believe there is a lot of potential with this technology. Hoping for a RealSense CHOP in the near future…


Hi Will,
Thanks for sharing.

Good work! Thanks for sharing with us.


I’ve had some requests to upload the .toe file, so here it is.
Also, I hear that Intel finally sent a DevKit to Derivative HQ. Any word on eventual RealSense OPs? Would be happy to help test them :nerd:

CutModRealSenseDemo.toe (4.92 KB)

Thanks for the upload. Realsense OP’s would be great.

I’m testing out the new RealSense CHOP in build 50500. After I got all my drivers up to date (a re-registration and 4 separate downloads from Intel) I was getting data! I was easily able to instance geometry on my hands/face. :smiley:

Then I tried to grab the video stream from the RealSense to overlay geometry on video. Adding a Video Device In TOP caused a pop-up error dialog “CoInitialization Error” and then selecting the RealSense RGB feed in the TOP’s device dropdown crashed Touch… I started a new project with Video Device In first, then tried adding RealSense CHOP. No crash, but no data in CHOP. Closed. Un/Re-plugged device. New Project. Start with CHOP, still no data. Restart computer (Retina MacBook Pro) Open Touch, no data. Un/Re-plug, re-open touch, now there’s data again… I think the device hadn’t fully enumerated yet after the reboot, before Touch opened. Is there a reason that the RealSense device needs to be plugged in before starting Touch or is that a bug? Same for using RealSense CHOP and Video Device In TOP concurrently?

We plan to add a RealSense TOP which will avoid the need to use it with the Video Device In TOP. We’ll look into this issue though.

Is anybody else getting a really slow frame rate whilst using the RealSense CHOP or TOP? I have an Intel 4770K with an Nvidia 970 and it’s slowing my system down to 17 FPS. Should it be doing this?

Which build are you using? We posted a new one yesterday with the TOP running much faster.

Brilliant! I just downloaded 52320 and now the frame rate is a cool 60FPS. I was on 51780 before.
Thanks Malcom :smiley:

Seems I spoke too soon.
I now get 60FPS on the RealSense TOP which is great! But when using the RealSense CHOP I still get a low 17FPS. Is this just teething problems with the CHOP Beta for now?

Hmm yes, not sure why it would slow down so much when using the CHOP. We’ll look into this.

Hey, we’ve found the bug on our side and fixed it. The next release will have the fix.

Which RealSense camera is supported? The F200 (close-up) or R200 (long-range)? or both?

I have installed :

Cant make Realsense Sensor run on touch,
every time i`m trying to place real sense chop its stuck.
when place the real sense top black image .

any ideas ?
which drivers you guys tested real sense with ?

It do works fine from time to time…
not sure yet what the routine I do in order it to work.

How do the SDK sample applications work for you?

Works well.
I first turn it on then close,
then open touch.

About Hands Image Position Option:
It seem to use the depth map space,
which is seem to be totally different then the RGB one in any resolution.

There is any option to add Hands Image Position to the RGB sensor too ?
(1.33 and 1.77 aspects)
NewProject.12.toe (5.53 KB)

I’m having similar issues with the RealSense TOP, just getting a black image. Using the r200 version of the RealSense camera ( and Touch 64-bit 52460.

It takes a few tries for the camera to get recognized by Windows, but once it is recognized the SDK tools and samples work fine.

The RealSense TOP is black. I do get an image from VideoInTOP using the WDM or Media Foundation libraries. RGB camera is fine in these modes (640x480 only), and the depth and IR images are visible (320x962, 8-bit only) though the image is left-half/right-half interlaced.

The RealSense CHOP does not show any data.

The VideoIN modes seem to be limitations of Intel’s drivers. I’m wondering if the RealSense TOP issues have to do with using the r200 camera instead of the f200? Are there certain driver versions that work better?

We have no yet gotten our hands on the r200, so I’m not sure if there is something else we need to do to support it.