Intel RealSense

getting depressed with the f200 :slight_smile:
It stop working from time to time and crash TD.
two errors messages i have tackled so far.
deppresed2.png
deppresed1.png

There seems to be a conflict with the R200 and the Video Device In TOP that can cause the CoInitialize error. Working on fixing that right now actually.

I didnt save and its hurt…
Screenshot 2015-08-07 21.37.57.png

Any plans to support soon the Intel® RealSense™ SDK for Windows R4 ?

Yes, we’ll be upgrading the SDK version soon enough. Please remember this is in the experimental version for a reason.

I know :slight_smile:
I`m doing some experiments with leap and RealSense sensors now.
will keep report :slight_smile:

Please let us know how your experiments go.
Have fun!

Just tested the updated RealSense TOP in the latest Experimental Build 54320, with the R200 camera. The color camera with one sensor now works in several resolutions (1920x1080, 1280x720, 640x480). All the other video streams result in an error. Middle-mousing indicates the error is an Intel SDK version issue and to upgrade to 6.0.21.6598, though that’s what’s installed. The same error occurs on subsequent TOPs when using more than one R200 camera.

I have a R200 on the way and will sort out the issues once I have it in-house.

Are ther plans to make the 22 hand joints accessible?

software.intel.com/sites/landin … oints.html

would be wonderfull!

Those are already accessible in the CHOP, no?

Oh sorry… and oh nice!

I couldnt find it in the wiki (derivative.ca/wiki088/index. … Sense_CHOP) and have no realsense to check it out. But now ill buy one!

thx again…

Is marker tracking available for the r200? I know the differences between the hardwares, but exactly what are the touch designer implementation differences between the f200 and r200? The wiki doesn’t state any functionality difference betweeen models with TD operators.

Malcolm :
Seem like we missing the option to get depth information on 60 fps.
search for “R200 Supported Configuration” in the PDF.
( unless i get it thru media foundation i think)

registrationcenter-download.inte … 016_r1.pdf

Yes, currently I run all of the cameras at 30fps so all the streams stay in closer sync. It’s a feature that could be added though.

Hi, I’ll write there without open a new thread.

I’ve upgraded to win 10 from 7 in order to use the realsense F200.
At the first time it wouldn’t work, so I’ve found this thead where is specificated to work with the R4 SDK.

After uninstalling the R1 2016. runtime and driver, I’ve found the 1.4 driver and the R4 runtime, but I’m still unable to find the R4 SDK.
Does someone has a direct link to download?

BTW it seems to work with previous and current TD version (58910 - 58620), but is very hard to get correct gesture recognition and often loses hand tracking.

Is it because I miss R4 SDK?

Is there a chance to work with the latest SDK which seams more accurate?

Thank you guys!

Here is a branch build compiled against the R6 SDK.
dropbox.com/s/7r65opltg47rk … t.exe?dl=0

Hi Malcolm
What are the plans with the real sense new sdk support?
2016 R1 seem to have so many features…

I got here the sr300 to play with, did not open it yet.

Any plan to add more features to the cameras FPS variable ?
are all camera inputs to touch (not only real sense) currently limit to 30fps ?

Hi,

I’m working with the SR300 in 099 and it’s been great so far. Thank you for the support. I’m running into a problem though relating to some of the laser power settings on the camera.

In my setup, the camera is facing down onto a table detecting hands and objects. The camera’s laser projection power seems to want to auto adjust, I’m guessing to try to get a good exposure range. The side effect is that it gives me noisy edges and a black halo on the background, which leads to messy foreground extraction. I’ve tried many materials (foamcore, cardboard, wood, different colored papers) but the effect is the same- the camera auto adjusts the laser power down. I’ve illustrated the effect in my attachment.

Some googling led me to this utility which has the ability to control the laser power along with other useful features like accuracy, motion range tradeoff, and depth confidence threshold. I was able to install and run this utility for the SR300 on Windows 10 and can confirm that setting the laser power level manually fixes my issue.
software.intel.com/en-us/forums … pic/537872

In the SDK, these all seem to be part of the Property enumerator:
software.intel.com/sites/landin … pture.html

or alternatively, part of the device interface:
software.intel.com/sites/landin … pture.html

The laser power level control would be extremely useful to me right now. Any of the others are icing on the cake.

I’d also be okay with writing a dll and adjusting these properties myself, but I don’t know how to access Touch’s Realsense Session instance.

Any help is much appreciated. Thank you!
realsense_autoexposure.jpg