Kantan Mapper - texture problem

Hello

I have been following the excellent tutorials on Kantan Mapper, but seem to be doing something wrong. I can add a texture to a quad, but I don’t see the texture after toggling it on. I can edit it in the “edit texture” window, and I see what ever color overlay I choose with no texture selected. I have tried multiple quads, sizing, resetting and virtually every option I can find. But I can’t get a texture to appear in a quad.
For reference I’m using a non commercial version: 099 64bit build 2017.11520 on a Windows 10 Dell laptop.
Any help would be appreciated.

Thanks

I am having the same problem with Kantan Mapper. I am using the Non-Commercial 99 64bit build 2017.10700 on a Mac Laptop with Sierra 10.12.5.

I tried the same software on a Windows 10 HP laptop, works perfectly.
I’m going to investigate drivers etc tomorrow, as it has to be a driver issue.

I am having the same problem with textures on a HP Z240 workstation,
with windows 10,
any solution?

i am having the same problem
the thing is that when i draw a rectangle, the resulting rectangle is a scaled version of a single pixel
here is a print screen:
imgur.com/a/zZMBz

Just checking to make sure you are all turning the texture “ON”. Beside the place where you drop in the texture, there is usually an “X”, you need to click that to turn it to a “Checkbox”. We are aware the “X” is not a good choice icon and this is confusing, we will update the UI in a future build. Is this the case for anyone, just that the checkbox is not turned on?

turnOnTexture.png

@mizdan - You do not have a texture assigned, so you will see the solid color of that shape until you assign a texture to it. Assigning a texture is shown in the documentation here:
derivative.ca/wiki099/index … _a_Texture

@fishbuster - Please try the latest build

When trying a new build, please get the a new Kantan Mapper from the palette as we are fixing bugs as we go.

I have the same problem with the non commercial version of Touchdesigner 2017.141620 recently installed on my Dell laptop, and the kantan mapper dragged into a project by the Palette. For Rectangles, I do not see the texture in the output window, but see it in the texture edit window. I have checked things and the texture button is in the correct status, checked and green.
I can see textures in freeforms and in the background.
I also notice that the scale values for rectangles is in fact their initial x and y size, while is set to 1,1 in freeforms.

Same as @romtouch. Touchdesigner non-commercial 64bit, build 2017.15400, Windows 10, Intel HD Graphics 620, Lenovo ThinkPad x1 carbon gen.5.

I have since updated to the commercial version, currently using the 64-bit Build 2017.15960
Still no textures working on Kantan Mapper. As others have mentioned here, I can see the quad, have control over it, etc. But do not see a texture when clicking the ‘X’ icon to turn it on.
I have tried KantanMapper on a different machine (a custom build laptop with a Nvidia card) and it works perfectly. So it appears it’s the Dell drivers that are the problem. I have updated those drivers repeatedly, re-installed Touch Designer repeatedly, and re-installed Windows a few times as well.
No luck.
A new problem has surfaced however. Now the realtime FPS on the Dell is never more than 48fps on a blank network.
None of this is a serious problem for me, I have another machine that I use for shows. But it’s interesting that updating the Dell drivers are only making the performance worse.
Any suggestions are welcome.

@avd Could you specify you complete hardware spec, GPU and driver most important.

Also, if you are updating the gpu drivers from Dell they are most likely out of date, manufacturers are terrible at staying up to date. I would recommend drivers from AMD or Nvidia directly. Or if you have Intel GPU or somehow can’t find the drivers on AMD/Nvidia, then this resource is amazing for getting the latest drivers
guru3d.com/files-categories/ … ivers.html

1 Like

@ben Thank you for the handy resource.
As requested, here is the hardware specs and GPU drivers etc.

Intel® HD Graphics 620
Driver Version: 22.20.16.4836
Operating System: Windows 10 Home (10.0.16299)
Physical Memory: 16272 MB
Vendor ID: 8086
Device ID: 5916
Device Revision: 02
Graphics Output Protocol (GOP) Version: 9.0.1067
Current Resolution: 3200 x 1800

Processor: Intel® Core™ i7-7500U CPU @ 2.70GHz
Processor Speed: 2904 MHz
Processor Graphics in Use: Intel® HD Graphics 620
Shader Version: 5.1
OpenGL* Version: 4.5
OpenCL* Version: 2.1
Vulkan* Version: 1.0.56

  • Microsoft DirectX* *
    Runtime Version: 12.0
    Hardware-Supported Version: 12.0

I did update to the latest Intel driver version for this GPU. This did fix the Kantan mapper texture problem. Although I’m still getting 48fps on a blank network.
I had to manually update the driver, as the Intel install complained of OEM incompatibility.

So now it’s:

Driver Version: 23.20.16.4901
Graphics Output Protocol (GOP) Version: 9.0.1067
Shader Version: 5.1
OpenGL* Version: 4.5
OpenCL* Version: 2.1
Vulkan* Version: 1.0.62

  • Microsoft DirectX* *
    Runtime Version: 12.0
    Hardware-Supported Version: 12.0

I really don’t expect great performance from an integrated GPU, but at least Kantan Mapper is working better now. thanks.

1 Like

You should make sure there’s no graphics switching going on. You should be able to go into the nVidia driver and force TouchDesigner to use the nVidia GPU, it might just be defaulting to Intel.

I was having the same issue viewing the texture inside the masks.

There are a couple of ways you can open kantanmapper, either by pulsing ‘Open Kantan Window’ or right clicking on kantanmapper window and selecting ‘View…’.

I was using the pulse option to work with the kantan window, when I ran into the texture issue. It seemed like it was just not saving the texture file path or the mask name. When I would close the window and open it again, these would get reset.

So I tried the View option to see if it would save these changes and sure enough, it works great now. I hope this is helpful. Cheers all.

Newb here - I’m not able to input a TOP into the texture field either through dragging or manual input. I tried opening Kantan Mapper with both “pulse” and “view” options - neither worked.
I’m using 099 on a mac running a Radeon Pro 560. Are drivers my issue too? Thx.

I found that I needed to use the “legacy drag system” in the Drag/Drop tab, not the “parent system” one… My fault.

I have a very weird issue on my workstation laptop (Lenovo P53; Quadro RTX 3000; i7 9th Gen; running on Win10):
My mouse-pointer keeps on “window resize-mode” (the two-sided arrow) and I cannot toggle anything…
I have tried to override the DPI-scaling, resize the kantan viewer etc, but I simply cannot toggle any output.
the window-border is also extraordinarily thick, which is different from my other desktop-workstation.
Does anyone else have that issue?

//edit:

I could solve the issue by going into kantanMapper’s network under …/kantanMapper/ui/manin/gadgets and under the Container’s “Panel”-section i disabled “Drag Edges to Resize” for the right edge.

this way i cannot resize the UI-section, but finally the toggling of the textures works…

Seems like the only answer related to the OP. I was going to ask if it (kantanMap) specifically is only working for GPU, but I guess it works with Intel int.graph. HD Graphics.
That’s good news! Although I am still having the same issue, but I’m running an older build on an older station so I’m sure that has something to do with it.

But thanks AVD and @ben!

@asantiago Can you try the latest build just to see if it helps? Then we will know the issue at least. You can always try it with a Non-Commercial license if your license’s Update Date has passed.

New Topic: for me.
Old: here.

KantanMapper- having an issue. Texture problems, you say?

So after searching I (in my case) finally figured out it all came down to GPU power.
Meaning, the actual presence of a video card dedicated to process graphics.

See…I pushed the limits of my CPU when I first started playing with TD, up until recently.

Even with no GPU, my i7 was doing pretty incredible, cool things - kinect stuff, audio reactive stuff, video blends and multi-BASE arrays, and then I arrived at testing projection.

I really thought I would (at the very least) get a Frankenstein of an image or render output, visible even if it is on a cheap projector and horrible resolution- I would have been cool with that!
I honestly thought my CPU can handle something like that (again, because I was very impressed what it was able to do with those other arrays.)

“Why don’t I see it at least in the viewer of kantan and in my little rectangle1?”

Well…I could not get texture to output, after trying almost all solutions I could find.
I was hesitant to invest in a new GPU without really knowing where the problem was
and
I was thrown off by how many people WITH gpus were suffering from the same thing- which confused me even more. It was hard to deduce, since ‘having a gpu’ also seemed to be doing somewhat the same thing. No texture, right?

Finally- I bought a GPU (I’m embarrased to say which one, but lets jsut say she met TD’s minimum asks) …had to clean out my tower anyway and give it the once-in-a-bluemoon thorough cleaning.

Sure enough, when I cranked it up for the first time with a dedicated GPU (after the configuration of monitors drivers and the usual hassle at the beginning of installing a new or first video card) – WHAM!!
I launched TD hopeful, and when I dropped the standard NewProject.toe’s output into the Texture of a rectangle in the viewer of Kantan (to test it quickly), and switched the little X to a checkmark…voila! I now see it in the viewer, and of course coming out of the projector and onto whatever I have it pointed at.

I just wanted to share- this thread already has so many things but hopefully someone who needs this answer, who was in the same boat as I was, can finally take the next step from having no GPU to buying one.

It is just going to be necessary, and I have seen some (unanswered) poor soul’s call-for-help on this thread, who are also trying to run Kantan and do some projecting with only their CPU’s onboard graphics.

All I’m saying is that you CAN do some pretty cool things with a powerful CPU, but for kantanMapper, you just KANT. Haha.

Happy 2021v2 Summer!

1 Like

I wasn’t able to fix this issue even with the M1 processor. However an alternative would be to download an older version of TouchDesigner and then you wont have a problem even if your running an i5 macbook air.