Kantan Mapper - texture problem

@stevekozinski Are you not able to get texture to display on your M1 Mac? Could you tell us which build you are using and which M1 mac you have?

I was using my mac mini (16GB Ram & M1 processor) and wasn’t able to load textures… same issue that some people above were mentioning (came out pixelated but showed up fine when clicking ‘edit texture’)
I was in a pinch for an event so I just downloaded the 2019 version of TD and that worked fine!

Hey Ben, I’m having the same issue as well with an M1 Max MacBook Pro 16" running Monterey 12.0.1.
I tried using the Apple silicon build and intel build. Both 2022.26590. Even the prior build to this, 2022.25370 was giving me the same problem. Any assigned texture is pixelated in the kantan window and output. However, when you click the “Edit Texture” window it displays the image/video properly. There are no issue displaying solid colors.

Here are some screenshots.



Okay thanks, I can reproduce it, looks like a shader issue that seemed to get through our testing for 2022 versions. We will look into what is wrong, thanks for the report.

Hey @ben, do You have any updates on this issue?
I’m experiencing the same error as @rossmonroe with the same build 2022.26590 on OSX 10.15.7
I have just bought TouchDesigner Commercial today for a video mapping and this feature is quite essential for me. Maybe are there any workarounds?

Yes, we found a fix (texture layers were not working correctly on macOS) and it will be in our next official build, we plan to post it next week.

Hey @ben ben and all,
great news and thanks for the fast fix! Looking forward to it.