Keyboard In DAT not working consistently with wireless pointer devices

I am having a bit of trouble with the Keyboard In DAT node. I have set up triggered events using various keyboard mapping (up, down, pageup, pagedown, etc.)
When I use the keyboard, I get very consistent results. The events trigger, no problem.
I test the wireless pointer devices (I have used 3 different models). They work fine with all other software, including PowerPoint, and when mapped to integers, they print the proper integers in all other software.
However, when I use the wireless pointers to trigger the Keyboard In DAT, it never works consistently, and sometimes not at all.
Has anyone out there come across this issues? Thanks.

Any thoughts here? Thanks.

I don’t have any experience with such devices. What specific device are you using?

I’ve used a few devices. All I’ve used have the same error. Ubuyone Wireless Presenter Remote on Amazon. Google will return the model. Can’t add a link here.

Like this model?

Yes, that’s the one.

We also tested simple one-button devices, with a 2.4ghz wireless transmitter, giving a simple integer (0 or 1) which we wired into the keyboard DAT. You can find these at places like quizgamebuzzers(dot)com, look in the wireless tab, go to “Power Grip Handheld Buzzers”. Windows sees these as an HID keyboard device. It types “0” or “1” into notebook or any other text app.

Any thoughts about this? I know it’s late on a Friday afternoon, but I’d love to know if this is something that we can resolve with a hardware switch, or another approach. Have a great weekend. Thanks again, Ben!

No idea as we have never used one of these devices. I asked the model so we might be able to pick one up and poke about with it, but no timeline on when that will be possible.

One question, are you having trouble when the Keyboard In DAT is visible on the screen? I am wondering if it could be a cooking issue when you are not directly looking at the DAT onscreen?

Hi Ben, I thought I’d jump in as Chris and I are working on this together. We did extensive testing and experimentation in the past couple days. We figured out that when using a wireless device, doesn’t matter which one we tried, the Keyboard In Chop shows the key and character correctly, but the state never changes, as it does when using a wired device. It’s always at 0. Could that be fixed in future versions? Or do you think that is just that we’re using devices that may not be sending a state change?

Anyway, I created a bit of python to detect the keypress in the Keyboard Chop In and got it working fine. So, we have a solution for this, I thought it was odd. Just wasn’t sure if this was a device issue or Touchdesigner issue.

Thanks for your time!

Thanks for the update. Another thought is have you guys looked at the Keyboard In DAT? It gives much more specific information on key presses, such as on/off, modifiers, and time pressed. It might help here as well.