Kinect v2 and Windows 11 Setup Issues (Connection Cycling)

My Kinect v2 will not stay connected to my Windows 11 machine for longer than 10 secs. I have ruled out the Kinect itself as the issue, as well as the power supply and connection adapter as the culprit.

I am running TouchDesigner 2023.11760 on Windows 11 build 23H2:
image

I have the Kinect Runtime v2.2_1905 and Kinect Configuration Verifier installed:

And have also tried installing the Kinect SDK 2 throughout my attempts to get my Kinect v2 working on my production machine.

I have the latest versions of the 3 Kinect-related drivers installed:



image

The Kinect v2 Configuration Verifier confirms that the Kinect is connected and detected:

But the Kinect appears to (possibly) have an audio driver conflict that causes the Kinect service to reboot constantly (every 10 or so seconds). And my audio services stops almost immediately after connecting my Kinect, and has to be manually restarted (though it shuts down shortly after).

I have enabled access in Microphone Privacy Settings for the Kinect Service (and all related instances of Kinect apps):

I have an Intel USB 3+ controller:
image

And have checked that the registry entry in {36fc9e60-c465-11cf-8056-444553540000} for LowerFilters is blank per Ghost Howls recommendation (How to fix Kinect v2 not working in Windows 10 Creators Update - The Ghost Howls).

And have tried using older (APO) drivers for Realtek Audio Effects Components (INT):
image

Per AR-Sandbox troubleshooting recommendations (Troubleshooting - AR-Sandbox.eu).

And I’ve confirmed my Kinect v2 is working in general, by running it on a Windows 10 machine. On the Windows 10 machine, the Kinect runs fine with these same drivers, and is seen by Kinect SDK 2 and TouchDesigner. I can bridge the Kinect v2 to TouchDesigner by connecting it to my Windows 10 machine via TouchIn and TouchOut to my Windows 11 instance, but it is a bit laggy, so I’d far rather solve the issue of the Kinect compatibility on my Windows 11 machine if possible.

I’m aware this is a similar post to this one here (Kinect keeps disconnecting - a possible solution), but the solution put forward did not solve my or others users’ problems in the thread, so hopefully this is not seen as a repost.

Has anyone else run into this issue, and found a solution? Kinect v2 offers a much better input signal for my StreamDiffusion projects than a typical webcam does, and I have projects using depth layers that I use in TouchDesigner that call for a Kinect.

Any help would be greatly appreciated, and likely would benefit others (I know I can’t be the only one running into issues with Kinect v2 and Windows 11 with Realtek & Intel SST drivers, as both are common on many laptops that have come out in the past few years).

Also, if you’re reading this and have a similar issue with Kinect v2 and Windows 11, can you comment below with what you’ve tried so far, in case we can potentially address the issue through process of elimination (and also draw some attention to this issue in searched google indexes from the forum)? Perhaps someone out there has the answer. Or at least, we can be sad together. :stuck_out_tongue:

I’m having the same issue with a V2 using a brand new Microsoft USB adapter. The biggest difference tho is that after connecting the V2 the Windows Audio Service immediately crashes and can not be brought back online, not even for a few seconds.

My research has led me to believe that this might be due to an incompatibility with the AMD 7945HX CPU or the ASUS motherboard I’m using, though the fact that you’re having the issue with an Intel CPU makes me think otherwise.

1 Like

My Windows Audio Service crashes immediately and can not be brought back online as well, even for a few seconds.

I’ve read up on this a ton, and do not believe your CPU or chipset is the issue… and believe that if you used a previous version of Windows, things would work fine (since I can get my Kinect running on my Windows 10 machine with different audio drivers, specifically without a microphone array).

The issue strongly points to a compatibility issue with Realtek’s drivers and Kinect’s audio stack.

Thanks for commenting! Follow this post in the event someone shows up eventually with a fix.

Also, one thing to consider for your situation is the Microsoft USB controller. I don’t think it will fix your problem, but the hardware requirements laid out by a number of people state “only Intel or Renesas chipsets are supported; Latest ASMedia chipset also works”. But again, because of your audio crashing issue (like mine), which shuts down the Kinect service, I think your controller is NOT your primary issue. It is however, the one thing you can easily try.