Kinect V2 instant disconnect/reconnect cycle (solved)

[EDIT]

for anyone else looking at this in the future:
solved it, it actually was a faulty usb-adapter. got a new one and everything works perfectly again.

[/EDIT]

Hey,

Since yesterday my Kinect V2 can’t connect to windows 10 - it disconnects and reconnects instantly. (see yt: /watch?v=EERTe1pLBDs ) DeviceManager keeps flashing/refreshing as well. The led on the camera lights up for a moment as well.

I tried every applicable step from msdn troubleshooting, but as it doesnt even get recognized as device i am really out of ideas by now. it is especially strange as everything was running perfectly before, and i am not aware of any changes on my system.

I have never seen this kind of behavior on any device, and it is really strange as windows does recognize the device as a kinect, but somehow loses connection right away …!?
I think it is different to the 10 second disconnect error, as it never establishes a connection at all anymore.

What i’ve tried so far:

  • reinstall kinect sdk + drivers
  • make sure all the audio/camera settings are correct
  • disconnect/reconnect^^
  • try different usb ports
  • roll back last windows update
  • and finally out of sheer frustration: a complete reset of my system.

… still no luck though, so I figured maybe someone here might have an idea what could be going on here?

Thanks!

Versions:

  • windows 10 build 1909 / 18363.1256
  • drivers + sdk 1905.16
  • my usb controller is not one of the recomended ones, but has been working with the kinect v2 before, so i don’t think that’s the problem…

Hey,

i had this problem a while ago and found this to work for me:

I’m also seeing something connected to the Microphone array:

https://social.msdn.microsoft.com/Forums/en-US/a2af9bf2-8d52-4406-98ef-0ae21ab25016/kinect-v2-freezing-then-restarting-repeatedly-within-a-few-seconds-even-with-samples?forum=kinectv2sdk

Cheers
Markus

Hey Markus,

Thanks for the reply!

I stumbled over this registry edit well, but it didn’t work for me. (the LowerFilters value didn’t exist in my registry - I added it, but it did nothing)

The microphone array shouldn’t be the problem either - I’ve allowed general microphone access, but I can’t change anything for the microphone array specifically as it doesn’t even show up anywhere. (The Kinect never stays connected long enough to register - it doesn’t even show up in the hidden devices in device-manager). Also, the microphe-array-dissconnect should take a bit longer?

Basically: as soon as i plug in the Kinect, I get the “windows device connected chimes” sound, but most of the time it doesn’t even play to the end before the disconnect-sound plays. It is really rejected right away… o. O

I am currently trying to get my hands on another poweradapter to test if maybe that’s the problem, but tbh I don’t think so. Otherwise I’m really out of ideas by now…

Thanks,

Manuel

Hello! I know maybe it’s an old issue and you’ve already solved it, but I’m trying to get my Kinect v2 to work on my new notebook as when I plug it in it starts to turn on and off continuously. I find it strange since in my previous notebook it works without problems. I currently have Windows 10, Intel I7 and installed KinectRuntime-v2.0_1409-Setup.
I already tried to solve the problem by editing the “LowerFilters” system registry, enabling the microphone privacy permissions for use in applications and some other things related to audio but without positive results.
Anyone know any way to solve it currently?