Kinect v2 Not Responding Specifically on TD

Hey, I’m trying to use a Kinect v2 to read a right hand input but it’s not giving any real data at all. Most other forums at least have some response, but I’m getting nothing. Ocassionally it show something on the CHOP, but nothing of value as it doesn’t move, then goes away. After a while the Kinect itself starts switching on and off.
As far as I know it’s not an issue with the hardware itself, running the SDK everything seems fine and I haven’t found any issues that way. Would anyone know a solution for this?

Well I got Kinect v2 working ok for one show a couple years ago but then it started switching on and off and glitching which seemed to be thermal related, as it started ok then got worse over time. I never did figure out if it was Kinect itself or the power adapter from Amazon. I also found it worked better on one particular USB port than others. So if you have not tried it yet, try every USB port on your machine. Good luck! Interested to hear what you learn.